RadListBox Height 100% not working in Mozilla Firefox

3 posts, 0 answers
  1. Imran Javed Zia
    Imran Javed  Zia avatar
    55 posts
    Member since:
    Jul 2009

    Posted 28 Sep 2010 Link to this post

    Hi,
    We have nested Rad Splitter and RadPane scenario. and in one place we have a RadListBox  in RadPane with 100% height and it take all the space in Internet Explorer. But is only show 3 rows height in Mozilla FireFox. 
             <telerik:RadPane ID="rp" runat="server" Width="100%" MinHeight="200" Scrolling="None" BackColor="Red">
                                                                <telerik:RadListBox
                                                                    runat="server" ID="lst"
                                                                    Height="100%" Width="250px"
                                                                    AllowReorder="true" OnClientDeleted="lstMeasuresItemDeleted"
                                                                    EnableDragAndDrop="true" SelectionMode="Multiple">
                                                                    <Items>                                                                                                                                       
                                                                        <telerik:RadListBoxItem Value="1" Text="A"/>
                                                                        <telerik:RadListBoxItem Value="2" Text="B"/>
                                                                        <telerik:RadListBoxItem Value="3" Text="C"/>
                                                                    </Items>   
                                                                </telerik:RadListBox>
                                                            </telerik:RadPane>
    Is there anyway to fix it for Mozilla Firefox to have 100% heigh in radpane.
    Thanks
  2. Imran Javed Zia
    Imran Javed  Zia avatar
    55 posts
    Member since:
    Jul 2009

    Posted 28 Sep 2010 Link to this post

    I have added a #lst_Panel style with height:100% and it has fixed the issue.
    But I am still curious, if it is the only way to handle this issue?
    Thanks 
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Sam
    Sam avatar
    60 posts
    Member since:
    Mar 2011

    Posted 09 Apr 2012 Link to this post

    Had this same issue.  Actually had to put #lstPanel (without the underscore) and it worked for me.  In case anyone else needs it.
Back to Top