Radhtmlfield paragraph problem

12 posts, 0 answers
  1. Pedro Santos
    Pedro Santos avatar
    1 posts
    Member since:
    Mar 2010

    Posted 17 Mar 2010 Link to this post

    Hello,

    I've experiencied a lots os glitchs in RadEditor for MOSS. The most of the them is about the alignment and position of paragraphs and tables. Many behaviors replaces my text with extra lines and put alignment that i have not set.

    Simple test is create 3 lines with break (enter key), next we wil make a paragraph in middle, using ctrl+enter. When we switch do html view or make a check in, the editor put an extra line after the paragraph. Sometimes we edit and remove the text and it fixes, sometimes he put again the extra ou double lines, and i can't win this battle!

    Another situation: many texts have bullets, when a user change a lot, sometimes the editor start to put extra lines with empty bullets at the end of the text. This is hard to explain how to achive this behavior, but i've see with my own eyes... look at this (http://conteudos.medinet-seguros.pt/produtosemvigor_/multiriscos/Seguro%20Casa/Pages/CapitaisSeguros.aspx)

    Could help me?

    RadEditor Version 5.3
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 18 Mar 2010 Link to this post

    Hi Pedro,

    There are a lot of improvements regarding the formatting and alignment in the latest version of RadEditor for ASP.NET AJAX 2010.Q1. RadEditor for MOSS 5.7.1 is based on this control. You can test its behavior in the following online demo http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx. If you decide that the new version meats your needs I suggest upgrading to it. You can find the instructions in the following online help article http://www.telerik.com/help/aspnet-ajax/upgrade_to_a_newer_version_of_radeditor_for_moss.html.


    Best wishes,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.

  3. Thomas
    Thomas avatar
    7 posts
    Member since:
    Apr 2010

    Posted 06 May 2010 Link to this post

    Hi,

    We also experience this problem. We have upgraded to the latest version of the RadEditor (v5.7.1) because of this behaviour. But even now we experience the same problems. We can't use the online demo to test our text, because the adding of extra lines beneath a bulleted list appears only after we have clicked the Save button. We can't find any Save button in the online demo.

    We have followed the guidlines when we upgraded this product.

    Thomas
  4. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 10 May 2010 Link to this post

    Hello Thomas,

    Could you please provide us with the HTML source, in which the problem appears? A step by step scenario of how to reproduce the issue will be helpful as well. Regarding the testing in the online demo http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx, in order to get the HTML that RadEditor actually generates you need to toggle between HTML and Design modes of the control.

    If you do not receive the extra lines after toggling between HTML and Design modes the problem is caused by the MOSS content filter. When you submit the page, MOSS will validate it and automatically make changes if the content is not valid. You can verify this by trying to enter the same content with the original SharePoint rich text editor.



    Regards,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. Mantas
    Mantas avatar
    7 posts
    Member since:
    Mar 2009

    Posted 08 Oct 2010 Link to this post

    Hello,

    I am getting problem with extra line during copy-paste from simple notepad on your given test link. This does not appear in Firefox but does appear in other browsers such as IE, Chrome.

    Any chance to avoid this?

    Kind Regards
    Mantas
  6. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 11 Oct 2010 Link to this post

    Hello Mantas,
    Could you provide me with the text, which you are coping from notepad? I will test it on our side and advise you further. A couple of screen shots will be helpful as well.

    Greetings,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  7. Mantas
    Mantas avatar
    7 posts
    Member since:
    Mar 2009

    Posted 11 Oct 2010 Link to this post

    Hi,

    Just any single line space is doubled after copy/paste into Rad Text Editor. This is true for all browsers apart from Firefox.

    Regards,
    Mantas
  8. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 11 Oct 2010 Link to this post

    Hi Mantas,

    Unfortunately I was not able to reproduce the issue. Could you provide me with your configuration files. These are ConfigFile.xml, ToolsFile.xml, ListToolsFile.xml, ListConfigFile.xml, which are located in the /Program Files/Common Files/Microsoft Shared/web server extensions/wpresources/RadEditorSharePoint/5.x.x.0__1f131a624888eeed/Resources/ folder. I will use them in order to make my test more accurate.


    Kind regards,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. Mantas
    Mantas avatar
    7 posts
    Member since:
    Mar 2009

    Posted 11 Oct 2010 Link to this post

    How strange is that...
    For todays sample image I used your given link in this post.
    http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx

    Maybe this is already old link or something?

    Kind Regards,
    Mantas
  10. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 12 Oct 2010 Link to this post

    Hi Mantas,

    I created a small video with my test. Please inform me if I am doing anything wrong in it: http://screencast.com/t/nYti0jBZoZkS

    All the best,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  11. Mantas
    Mantas avatar
    7 posts
    Member since:
    Mar 2009

    Posted 12 Oct 2010 Link to this post

    Wow,
    Thanks a lot for impressive efforts regarding my post. I doubled checked main browsers again in demo link. I must apologise for IE8. It does work, I must have mixed something. However, chrome is surely doing something strange. These are html outputs that I get for copy/paste.


    Note Pad:
    "Text

    Some more text"


    FireFox:
    "text<br />
    <br />
    Some more text"
    - good

    Chrome:
    "Text<br />
    <br />
    <br />
    Some more text"
    - extra <br/>
     
    IE8:
    "<p>Text</p>
    <p>Some more text</p>" - good
  12. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 13 Oct 2010 Link to this post

    Hi Mantas,

    Unfortunately the problem is that different browsers interpret the text, which is in the clipboard differently and produce different HTML code. So in IE there are two paragraphs, in FF there are two BR elements and in Chrome there are three BR elements. Unfortunately there is no known workaround for his problem.


    Greetings,
    Stanimir
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top