RadGridView weird behavior

7 posts, 1 answers
  1. Todor
    Todor avatar
    13 posts
    Member since:
    Nov 2008

    Posted 22 Nov 2010 Link to this post

    Hi,
    I experience a weird behavior of the RadGridView with row and column virtualization turned on. At random times, upon setting the ItemsSource property, a single selected row remains 'hanging' in the empty area far down the last row in the grid. I have attatched a screenshot with visual representation of the problem. Turning the virtualization off solves this issue but it's inacceptable due to the large amount of the data that used with the grid. I am using version Q1 SP1 2010 of the grid.
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 22 Nov 2010 Link to this post

    Hi Todor,

     Can you post more info about the grid version? Is it our latest Q3 2010?

    All the best,
    Vlad
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for WPF
  3. UI for WPF is Visual Studio 2017 Ready
  4. Todor
    Todor avatar
    13 posts
    Member since:
    Nov 2008

    Posted 22 Nov 2010 Link to this post

    Hi Vlad, I updated my original post, it's v. Q1 SP1 2010
  5. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 22 Nov 2010 Link to this post

    Hello Todor,

     Can you update to some of our more recent versions? We had such issues before however I believe that they were fixed. 

    Kind regards,
    Vlad
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for WPF
  6. Todor
    Todor avatar
    13 posts
    Member since:
    Nov 2008

    Posted 22 Nov 2010 Link to this post

    We are working on a huge project and we already spent a great amount of time on customizing the behavior of many of the controls. It is very likely that if we upgrade the controls to the latest version, some of this functionality will break and we will have to spend an indetermined amount of time on debugging and refactoring the code. We already once had to go through this with previous updates. We are currently at a stage where we can't afford this extra work (and time) and I would greatly appreciate any hint or work-around that you can give me on this issue. Thanks for your swift replies!
  7. Answer
    Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 22 Nov 2010 Link to this post

    Hi Todor,

     Please open support ticket and send us small example where we can reproduce this behavior. I'll gladly assist you to find a workaround. 

    Best wishes,
    Vlad
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for WPF
  8. Todor
    Todor avatar
    13 posts
    Member since:
    Nov 2008

    Posted 22 Nov 2010 Link to this post

    Hi Vlad,

    Thanks. I will try to extract this into a sample project and I will send it to you as soon as my company renews our subscription. However, this behavior happens very randomly and I'm not quite certain that it will be easily reproducible even with the sample project. Thanks for your time once again.
Back to Top
UI for WPF is Visual Studio 2017 Ready