RadGrid Row Select Scrolls Pane to Top

3 posts, 1 answers
  1. Richard Weeks
    Richard Weeks avatar
    95 posts
    Member since:
    Oct 2009

    Posted 18 Apr 2011 Link to this post

    I have 3 panes within a splitter arranged as [ 1 | 2 | 3 ].

    I have a RadGrid in 1 and 2. Selecting an item from the grid in 1 loads up child data in 2. Selecting a row from the grid in 2 displays information for the selected item in 3.

    The issue I have encountered is that when there are many rows in 2 to the extent that a vertical scrollbar appears in 2, scrolling down and selecting a row in the radgrid in 2 causes the pane to scroll to the top, losing the user's reference to that selected row.

    How can I prevent 2 from scrolling to the top when a grid row gets selected?

    Richard
  2. Answer
    Dobromir
    Admin
    Dobromir avatar
    1633 posts

    Posted 20 Apr 2011 Link to this post

    Hi Richard,

    This behavior might occur in case where the grid located in the second pane have enabled KeyboardNavigation. If this is the case, this is a standard browser behavior - when KeyboardNavigation is enabled when a row is selected the whole grid element is focused, and under Internet Explorer is trying to navigate to the top or bottom of the focused element. To avoid this behavior you need to disable the RadGrid's keyboard navigation.

    If this is not the case, could you please provide more detailed information on the specific scenario:
    • Which version of RadControls for ASP.NET AJAX and .NET Framework are used in the application?
    • Under which browser and its version the problem occurs?
    • Could you please provide a simple fully runnable project reproducing the problem so we can investigate it further?

    All the best,
    Dobromir
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Richard Weeks
    Richard Weeks avatar
    95 posts
    Member since:
    Oct 2009

    Posted 20 Apr 2011 Link to this post

    Thank you for your quick reponse.

    Setting ClientSettings AllowKeyboardNavigation="false"  stopped the scrolling.

    Many thanks!

    Richard
Back to Top