Radgrid inside radmultipage : Error: Sys.ArgumentException: Value must not be null for Controls and Behaviors. Parameter name: element

2 posts, 0 answers
  1. pratik
    pratik avatar
    2 posts
    Member since:
    Apr 2009

    Posted 10 Jul 2009 Link to this post

    Here is my page code:

    <asp:Content ID="Content1" runat="server" ContentPlaceHolderID="MasterContentPlaceHolder">
        <telerik:RadAjaxLoadingPanel ID="LoadingPanel" runat="server">
                <img src='<%= RadAjaxLoadingPanel.GetWebResourceUrl(Page, "Telerik.Web.UI.Skins.Default.Ajax.loading7.gif") %>'
                    alt="Loading..." style="border: 0;"/>
            </telerik:RadAjaxLoadingPanel>
        <telerik:RadAjaxManagerProxy ID="ajaxProxyContracts" runat="server">
            <AjaxSettings>
                <telerik:AjaxSetting AjaxControlID="tsContractCapture">
                    <UpdatedControls>
                        <telerik:AjaxUpdatedControl ControlID="tsContractCapture" />
                        <telerik:AjaxUpdatedControl ControlID="mpContractCapture" LoadingPanelID="LoadingPanel" />
                    </UpdatedControls>
                </telerik:AjaxSetting>           
            </AjaxSettings>
        </telerik:RadAjaxManagerProxy>
        <telerik:RadTabStrip AutoPostBack="true" ID="tsContractCapture" OnTabClick="tsContractCapture_TabClick" runat="server" MultiPageID="mpContractCapture">
            <Tabs>
                <telerik:RadTab runat="server" Value="0" Text="General" Selected="true" PageViewID="pvGeneral">
                </telerik:RadTab>           
                <telerik:RadTab runat="server" Value="2" Text="Performance" Visible="false" PageViewID="pvPerformance">
                </telerik:RadTab>         
            </Tabs>
        </telerik:RadTabStrip>
        <asp:HiddenField ID="hdnContractID" runat="server" Value="-1" />
        <telerik:RadMultiPage ID="mpContractCapture" runat="server" Width="100%">
            <telerik:RadPageView BorderColor="Gray" Selected="true" BorderStyle="Solid" BorderWidth="1" ID="pvGeneral"
                runat="server">
                <Control:General ID="ucGeneral" runat="server" />
            </telerik:RadPageView>      
            <telerik:RadPageView ID="pvPerformance" runat="server">
                <Control:Performance ID="ucPerformance" runat="server" />
            </telerik:RadPageView>
         
        </telerik:RadMultiPage>
    </asp:Content>

    here is my performance user control(just only rad grid).

    <telerik:RadGrid ID="dgPerformanceComponent" runat="server" >   
    </telerik:RadGrid>


    I am receiving following error..Any suggestionss???
     Error: Sys.ArgumentException: Value must not be null for Controls and Behaviors. Parameter name: element
  2. pratik
    pratik avatar
    2 posts
    Member since:
    Apr 2009

    Posted 11 Jul 2009 Link to this post

    Hi,

          I found the issue.. I have a AutoEventWireup=false for that control.. that's why it gives error. sorry for that...

       

    Thanks..
Back to Top