RADGrid displays incorrectly in Safari with AllowFilteringByColumn="true"

5 posts, 0 answers
  1. Andrew
    Andrew avatar
    14 posts
    Member since:
    Apr 2009

    Posted 12 Jan 2010 Link to this post

    Hi, I'm developing an application that uses RadGrid and noticed this evening that it works fine under IE, but not under Safari.  This applies whether I'm using Safari on Windows or on my iPhone.  Specifically, if I have the AllowFilteringByColumn="false", the grid displays fine.  If I set it to true, then the grid becomes nearly infinitely wide in Safari with a huge horizontal scroll...yet works fine in IE either way.

    Is this a known issue in Safari?  I'm using Q3 2009 version...any help is greatly appreciated as I'd like my app to be cross-platform...

    Thanks,
    Andrew
  2. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 13 Jan 2010 Link to this post

    Hi Andrew,

    I tried to replicate the issue you are facing but to no avail. RadGrid behaves the same way under IE and Safari. Please find attached a simple runnable project which is working properly. Examine it and let me know what is the difference in your scenario.

    Best wishes,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Jeremy Wadsworth
    Jeremy Wadsworth avatar
    41 posts
    Member since:
    Mar 2006

    Posted 13 May 2010 Link to this post

    This is indeed an issue. I just spend a couple hours narrowing it down. I'm using Q1 2010 309.20, with Safari 4.0. The grid displays fine in IE 7 and IE 8.

    I have 6 columns in my grid, the last being a GridDateTimeColumn. The grid displays fine until I set AllowFiltering="True" for the GridDateTimeColumn. Once I set that property to true, the GridDateTimeColumn stretches horizontally, probably 50,000 pixels. Also, the filter and date picker icons sit on top of each other. Additionally, the paging area craps out.

    I've attached two screenshots. The normal looking one is with AllowFiltering="false" set on the Last Modified column. 

    Jeremy
  5. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 13 May 2010 Link to this post

    Hi Jeremy,

    To avoid this issue, you should set the FilterControlWidth property for the DateTime column in pixel as in the online example below:
    http://demos.telerik.com/aspnet-ajax/grid/examples/generalfeatures/filtering/defaultcs.aspx

    Give it a try and let me know how it goes.

    Best wishes,
    Pavlina
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  6. Jeremy Wadsworth
    Jeremy Wadsworth avatar
    41 posts
    Member since:
    Mar 2006

    Posted 13 May 2010 Link to this post

    Setting the FilterControlWidth resolves the issue in Safari and Chrome. Thank you.

    It would have been nice had this been pointed out somewhere as a known issue. I suppose now this forum thread will serve as the resource I was looking for.

    Thanks again.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017