RadFrom display problem

5 posts, 1 answers
  1. Cristian Apavaloaiei
    Cristian Apavaloaiei avatar
    25 posts
    Member since:
    Aug 2008

    Posted 03 Aug 2010 Link to this post

    Hello,
    I'm having problems with the RadForm component. This problem appears to me both in Q1 2010 and Q2 2010, .NET Framework 4. I'm running Windows 7 and using VS 2010. The problem is that the form does not appear to style itself correctly. I've attached a screenshot to show you the problem. I'm confused as to what is causing this problem, because I don't recall having this issue with Q2 2008 or even Q1 2010 before i had it uninstalled and installed again.

    Thank you.

    Edit: The form appears correctly in the Visual Studio Designer, the problem appears only when running the application.
  2. Answer
    Deyan
    Admin
    Deyan avatar
    2039 posts

    Posted 03 Aug 2010 Link to this post

    Hi Cristian Apavaloaiei,

    Thanks for contacting us.

    I cannot see any undesired appearance in the RadRibbonForm in the screenshot that you have attached. Please note, that whenever you are using RadRibbonForm or RadForm with a RadRibbonBar control on it, the form automatically positions the RadRibbonBar half-way on the glassy title bar just as Microsoft Office 2007 applications do.

    In RadRibbonForm, however, you can turn off this behavior and make the form appear the same way as in the Visual Studio Designer. You can do this by setting the AllowAero property of the form to false. You can do this in the form's constructor, after the InitializeComponent method call.

    I hope this helps.

    Kind regards,
    Deyan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Cristian Apavaloaiei
    Cristian Apavaloaiei avatar
    25 posts
    Member since:
    Aug 2008

    Posted 04 Aug 2010 Link to this post

    I didn't know about the AllowAero property, thanks.
  5. waseem
    waseem avatar
    32 posts
    Member since:
    Jun 2006

    Posted 09 Sep 2010 Link to this post

    Dear ,

    I have the same issue with RadRbibbon Form. its not showing proper theme. even i drag a Desert theme on Form.

    i can't find the AllowAero property.

    i was checking your demo as well there is no AllowAero property used.

    in demo MDI Form is used normal RadForm which works fine with me, Issue in RadRibbon Form.

    Regards,
  6. Stefan
    Admin
    Stefan avatar
    2891 posts

    Posted 14 Sep 2010 Link to this post

    Hello waseem,

    Please find the answer to your question in this forum thread: http://www.telerik.com/community/forums/winforms/forms-and-dialogs/radribbonform-and-default-theme.aspx

    Kind regards,
    Stefan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top
UI for WinForms is Visual Studio 2017 Ready