RadForm loading speed??

2 posts, 0 answers
  1. sangki
    sangki avatar
    9 posts
    Member since:
    Apr 2009

    Posted 27 May 2009 Link to this post


    Problem, It is the RadForm loading slow speed.

    Please tell us how you can improve
  2. Deyan
    Deyan avatar
    2026 posts

    Posted 28 May 2009 Link to this post

    Hi Sangki,

    Thanks for writing.

    I would like to inform you that in Q1 2009 SP1 release we have introduced some major changes in RadForm which altered the user experience with this control by significantly increasing the performance.

    However, could you please share with us some more details on the case so that we can investigate it and provide proper support. We would appreciate information about the structure of your Form, i.e. how many controls have you put on it, are there any standard .NET controls on it etc.

    It will be of a great help if you manage to create a simple Windows Forms project that manages to reproduce this behavior so that we can take a look at it.

    Nevertheless, we have made a test of the loading speed of our Form and with the latest version of our controls it loads fine. Please note that due to the additional functionality that comes with RadControls for WinForms, there are some performance penalties because our components use much more GDI painting and load additional resources (themes, images) as well.

    Thanks for your time.

    I am looking forward to receiving the requested details .

    Kind regards,
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. DevCraft banner
Back to Top