RadEditor Spell / Image gallery

14 posts, 0 answers
  1. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 10 Jul 2008 Link to this post

    Hi we have radeditor installed and almost working on our Moss 2007 setup, however the Image Gallery and Spell checker dont work.

    When clicking the spell checker the spell checker loads up and just stays there meaning a user has to exit the page and start again.

    The image gallery /  insert picture icon on the toolbar does not show any pictures in the browse window even if there are pictures in the folder.

    Any ideas (please)!!!

     Cheers Damien

  2. George
    Admin
    George avatar
    859 posts

    Posted 15 Jul 2008 Link to this post

    Hi Damien,

    Could you please clarify, have you set the Image Manager's ImagesPaths property to point to the desired image library? For more information please review the following help article:  
    http://www.telerik.com/help/aspnet-ajax/set-properties-via-config-file.html

    "When clicking the spell checker the spell checker loads up and just stays there meaning a user has to exit the page and start again."
    I am not sure what the reason for this problem might be. Please check the behavior using Fiddler. What is the result? Are all the resources loaded correctly?

    If you still experience the problems, please open a support ticket and send us some screenshots that demonstrate the behavior, along with more information about your current scenario.

    Sincerely,
    George
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 15 Jul 2008 Link to this post

    Hi George

    I tried following that FAQ for the image gallery my file location was 4.5.0.0__1f131a624888eeed\RadControls\Editor so am guessing I have an older version of RAD Editor installed.

    No I am getting the following error Microsoft.SharePoint.SPException: "/_catalogs/" contains reserved name. Please try another one.

    Even after changing the file back

     <?xml version="1.0" encoding="utf-8" ?>
    <!-- ==============================================================================================
     Config File valid structure:
     <configuration>
        <property>...</property>
        ...
      <property>
       <item>...</item>
       <item>...</item>
       ...
      </property>
      ...
     </configuration>
    =============================================================================================== -->
    <configuration>
      <property name="AllowThumbGeneration">True</property>
      <property name="ConvertToXhtml">True</property>
      <property name="EnableDocking">False</property>
      <property name="ShowHtmlMode">True</property>
      <property name="ShowPreviewMode">False</property>
      <property name="StripAbsoluteAnchorPaths">False</property>
      <property name="StripAbsoluteImagesPaths">False</property>
      <property name="StripFormattingOnPaste">MSWordRemoveAll,Span,Font</property>
      <property name="ToolbarMode">ShowOnFocus</property>
      <property name="ToolsWidth">800px</property>
      <property name="Skin">Default2006</property>
      <property name="SpellDictionaryLanguage">en-GB</property>
      <property name="SpellDictionaryPath">~/RadControls/Spell/TDF/</property>
    </configuration>

    Any ideas regards Damien
  4. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 15 Jul 2008 Link to this post

    Hi me again;

    I am unable to submit a support ticket as I dont have any products under my name;

    I have managed to get the image library working but now have issues with the spell checker still

    As the Spell checking in progress...bar keeps on running, I cant see any issues in Fiddler although when I tried changing from Ajax spell to normal spell I got this error. - Could this be causing the issue??

    Regards Damien

    Server Error in '/' Application.


    Compilation Error

    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0433: The type 'Telerik.WebControls.Spell.DialogHandler' exists in both 'c:\WINDOWS\assembly\GAC_MSIL\RadSpell.Net2\3.2.5.0__b5dad7bf2bf594c2\RadSpell.Net2.dll' and 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\assembly\dl3\1a0c08ca\83f17652_2790c801\RadSpell.Net2.dll'

    Source Error:

     

     

    [No relevant source lines]


    Source File: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\App_Web_telerik.spell.dialoghandler.aspx.c921b10c.mvrs3ir1.0.cs    Line: 98

    Show Detailed Compiler Output:

     

     

    c:\windows\system32\inetsrv> "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\csc.exe" /t:library /utf8output /R:"C:\WINDOWS\assembly\GAC_MSIL\Rapid.SharePoint.Publishing\1.1.0.0__0b6168c71753d3c2\Rapid.SharePoint.Publishing.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\RadSpell.Net2\3.2.5.0__b5dad7bf2bf594c2\RadSpell.Net2.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\App_GlobalResources.pc0bieov.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\mscorlib.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Drawing\2.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Xml\2.0.0.0__b77a5c561934e089\System.Xml.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\Rapid.SharePoint.Classification\1.1.0.0__8f9625cafc8befbd\Rapid.SharePoint.Classification.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\assembly\dl3\42405e2b\02d6c793_1590c801\CKS.Bamboo.WorldClockAndWeatherService.DLL" /R:"C:\WINDOWS\assembly\GAC_32\System.Data\2.0.0.0__b77a5c561934e089\System.Data.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.IdentityModel\3.0.0.0__b77a5c561934e089\System.IdentityModel.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Web.Mobile\2.0.0.0__b03f5f7f11d50a3a\System.Web.Mobile.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System\2.0.0.0__b77a5c561934e089\System.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.ServiceModel\3.0.0.0__b77a5c561934e089\System.ServiceModel.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\assembly\dl3\554eba34\02d6c793_1590c801\CKS.Bamboo.MsnWeatherProvider.DLL" /R:"C:\WINDOWS\assembly\GAC_32\System.Web\2.0.0.0__b03f5f7f11d50a3a\System.Web.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\RadEditorSharePoint\4.5.3.0__1f131a624888eeed\RadEditorSharePoint.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\AjaxPro.2\7.7.31.1__eabb1b8f6347d5af\AjaxPro.2.dll" /R:"C:\WINDOWS\assembly\GAC_32\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Configuration\2.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Web.Services\2.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\App_global.asax.sn3iovy6.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\Microsoft.SharePoint\12.0.0.0__71e9bce111e9429c\Microsoft.SharePoint.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\RadEditor.Net2\7.3.3.0__852c9eb6525c1b53\RadEditor.Net2.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\assembly\dl3\8ae5b06f\02d6c793_1590c801\CKS.Bamboo.WorldClockAndWeather.DLL" /R:"C:\WINDOWS\assembly\GAC_MSIL\Rapid.SharePoint\1.1.0.0__40c83c838317c760\Rapid.SharePoint.dll" /R:"C:\WINDOWS\assembly\GAC_MSIL\System.Runtime.Serialization\3.0.0.0__b77a5c561934e089\System.Runtime.Serialization.dll" /R:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\assembly\dl3\1a0c08ca\83f17652_2790c801\RadSpell.Net2.DLL" /out:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\App_Web_telerik.spell.dialoghandler.aspx.c921b10c.mvrs3ir1.dll" /debug- /optimize+ /w:4 /nowarn:1659;1699;1701  "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\App_Web_telerik.spell.dialoghandler.aspx.c921b10c.mvrs3ir1.0.cs" "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\App_Web_telerik.spell.dialoghandler.aspx.c921b10c.mvrs3ir1.1.cs"

     

     

    Microsoft (R) Visual C# 2005 Compiler version 8.00.50727.1433

    for Microsoft (R) Windows (R) 2005 Framework version 2.0.50727

    Copyright (C) Microsoft Corporation 2001-2005. All rights reserved.

     

    c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\App_Web_telerik.spell.dialoghandler.aspx.c921b10c.mvrs3ir1.0.cs(98,164): error CS0433: The type 'Telerik.WebControls.Spell.DialogHandler' exists in both 'c:\WINDOWS\assembly\GAC_MSIL\RadSpell.Net2\3.2.5.0__b5dad7bf2bf594c2\RadSpell.Net2.dll' and 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\assembly\dl3\1a0c08ca\83f17652_2790c801\RadSpell.Net2.dll'

    c:\WINDOWS\assembly\GAC_MSIL\RadSpell.Net2\3.2.5.0__b5dad7bf2bf594c2\RadSpell.Net2.dll: (Location of symbol related to previous error)

    c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\5a428896\ecf709a0\assembly\dl3\1a0c08ca\83f17652_2790c801\RadSpell.Net2.dll: (Location of symbol related to previous error)

     


    Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

  5. George
    Admin
    George avatar
    859 posts

    Posted 16 Jul 2008 Link to this post

    Hi Damien,

    I can see that you are using the Light version of RadEditor for MOSS, which is provided as it is. Please open the ToolsFile.xml or ListToolsFile.xml (this depends on your scenario) and make sure that you are using the AjaxSpellCheck tool. Is the problem still observed?

    If yes please open the ConfigFile.xml/ListConfigFile.xml and change the SpellDictionaryPath as follows:
    /_wpresources/RadEditorSharePoint/4.x.x.x__1f131a624888eeed/RadControls/Spell/TDF - please change the x-es with your exact version. Is the problem still observed?

    Best wishes,
    George
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 16 Jul 2008 Link to this post

    Hi, yes I have checked that and still not working

    Could it be an issue with DLL files??  Where should RadSpell DLL be (where is it needed)

    Fiddler info is ---

    POST http://intouch.tewv.nhs.uk/_wpresources/RadEditorS...CheckHandler.ashx?RadUploadTimeStamp=1216208235584 74ms

    CommandArgument The quick brown fox jumped over the lazy dog<br>

    CommandName SpellCheck Configuration 
    RGljdGlvbmFyeVBhdGgsRmFsc2UsMCxRenBjVUhKdlozSmhiU0JHYVd4bGMxeERiMjF0YjI0Z1JtbHNaWE5jVFdsamNtO
    XpiMlowSUZOb1lYSmxaRnhYWldJZ1UyVnlkbVZ5SUVWNGRHVnVjMmx2Ym5OY2QzQnlaWE52ZFhKalpYTmNVbUZrUldScG
    RHOXlVMmhoY21WUWIybHVkRncwTGpVdU15NHdYMTh4WmpFek1XRTJNalE0T0RobFpXVmtYRkpoWkVOdmJuUnliMnh6WEZ
    Od1pXeHNYRlJFUmc9PTtDdXN0b21EaWN0aW9uYXJ5U3VmZml4LEZhbHNlLDAsTFVOMWMzUnZiUT09O1NwZWxsQ2hlY2tQ
    cm92aWRlcixGYWxzZSwyLDA7RWRpdERpc3RhbmNlLEZhbHNlLDEsMTtXb3JkSWdub3JlT3B0aW9ucyxGYWxzZSwyLDQ7Q
    3VzdG9tRGljdGlvbmFyeVNvdXJjZVR5cGVOYW1lLEZhbHNlLDAsO0ZyYWdtZW50SWdub3JlT3B0aW9ucyxGYWxzZSwyLD
    A= DictionaryLanguage en-GB
  7. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 16 Jul 2008 Link to this post

    Error message in event viewer on MOSS server.
    Load control template file /_controltemplates/RadEditorList.ascx failed: Could not load file or assembly 'RadEditorSharePoint, Version=4.5.0.0, Culture=neutral, PublicKeyToken=1f131a624888eeed' or one of its dependencies. The system cannot find the file specified.






    I think this may be one of the issues??

    Regards

    Damien

    ps I have manager to make the Image Manager work, 1 down 1 to go, thanks for you help.

    =0)
  8. George
    Admin
    George avatar
    859 posts

    Posted 17 Jul 2008 Link to this post

    Hi Damien,

    Have you upgraded by any chance to a new version of the control? In addition, please check the server's GAC for the following assemblies:

    • System.Web.Extensions
    • Telerik.Web.UI
    • Telerik.Charting
    • RadEditorSharepoint

    Are they present?

    Looking forward to hearing from you, George
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  9. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 17 Jul 2008 Link to this post

    Hi George

    Yes have upgraded to the latest Lite RadEditor for MOSS Version=4.5.3.0,
    have checked the GAC and the only assemblies I can find are 

    RadEditor.Net2
    RadEditorSharepoint
    RadSpell.Net2

    Regards

    Damien

  10. George
    Admin
    George avatar
    859 posts

    Posted 17 Jul 2008 Link to this post

    Hi Damien,

    Most probably your installation is corrupted. Have you followed the exact upgrade instructions? What we suggest is to uninstall RadEditor and Install it again. Please use the articles bellow:
    I hope this helps.

    Sincerely,
    George
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  11. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 17 Jul 2008 Link to this post

    Hi George; your probably getting fed up of me by now lol =0)

    Have uninstalled RadEditor by using the instructions provided and then reinstalled but still Spell Checker and Ajax spell checkers dont work.

    No errors are appearing its just making the Ajax Spell checker status bar move as though it is working correctly.

    Regards

    Damien
  12. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 17 Jul 2008 Link to this post

    Hi George;

    Have just tried running the SpellChecker on firefox and firebug identified these errors, maybe these can help??

     
    this.ContentDisplay is null
    IgnoreHandler()(click clientX=383, clientY=79)WebResou...327015298 (line 43)
    if(this.ContentDisplay.IsEditMode){
    WebResou...327015298 (line 43)
    this.SpellProcessor is null
    CancelHandler()(click clientX=222, clientY=280)WebResou...327015298 (line 89)
    CreateEventHandler()()WebResou...327015298 (line 23)
    this.CloseDialog(this.SpellProcessor.IsT...&confirm(this.Localization["Confirm"]));
    WebResou...327015298 (line 89)
    this.SpellProcessor is null
    IgnoreAllHandler()(click clientX=411, clientY=111)WebResou...327015298 (line 51)
    CreateEventHandler()()WebResou...327015298 (line 23)
    this.SpellProcessor.IgnoreAll();
    WebResou...327015298 (line 51)
    this.SpellProcessor is null
    AddCustomHandler()(click clientX=407, clientY=147)WebResou...327015298 (line 55)
    CreateEventHandler()()WebResou...327015298 (line 23)
    var _a=this.SpellProcessor.GetCurrentBadWord().wordString;
    WebResou...327015298 (line 55)
    this.ContentDisplay is null
    ChangeHandler()(click clientX=407, clientY=165)WebResou...327015298 (line 75)
    CreateEventHandler()()WebResou...327015298 (line 23)
    this.ChangeCurrentWord(this.ContentDisplay.GetReplacementWord());
    WebResou...327015298 (line 75)
    this.SpellProcessor is null
    ChangeAllHandler()(click clientX=406, clientY=189)WebResou...327015298 (line 77)
    CreateEventHandler()()WebResou...327015298 (line 23)
    if(this.SpellProcessor.AreAllWordsFixed()){
    WebResou...327015298 (line 77)
  13. George
    Admin
    George avatar
    859 posts

    Posted 21 Jul 2008 Link to this post

    Hi Damien,

    Please open a support ticket and send us more details about your exact scenario:
    We will review the details and do our best to provide a solution.

    Sincerely,
    George
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  14. damien
    damien avatar
    10 posts
    Member since:
    Jul 2008

    Posted 21 Jul 2008 Link to this post

    Hi George

     

    Thank you for submitting your inquiry to the Telerik Support.

    Your ticket ID is : 150955

Back to Top