RadEditor problem in IE

8 posts, 0 answers
  1. Velkumar
    Velkumar avatar
    85 posts
    Member since:
    Apr 2011

    Posted 27 Jun 2012 Link to this post

    Hi,

          

     I have a radeditor  in my page. It works and looks fine in firefox and opera but it will display  in IE as an another control. I attached the screen shots of 3 browser.

    Thanks

    Velkumar

       

  2. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 02 Jul 2012 Link to this post

    Hello Velkumar,

    The problem could be due to:

    - More that 31 CSS files on the page in IE9 - see this blog post on the subject Internet Explorer CSS limits

    - or due to global CSS class(es) that breaks the appearance of RadEditor - disable the page stylesheet and see whether the editor will be loaded as expected.

    If you are unable to fix the appearance problem, open a support ticket and provide a simple working demo which demonstrates it.

    Best regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Jocelyn
    Jocelyn avatar
    148 posts
    Member since:
    Jul 2012

    Posted 11 Sep 2012 Link to this post

    Hi, I have a very similar problem, but I tried these tricks, but none worked for me.

    The difference is that my RadEditor is inside a RadGridEditForm. I attached two images showing what it is looking in every IE version.

    Any suggestion to fix this?
  5. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 12 Sep 2012 Link to this post

    Hello,

    See this sticky forum thread for information how to solve this appearance problem: http://www.telerik.com/community/forums/aspnet-ajax/editor/incorrect-rendering-of-radeditor-when-shown-with-ajax-in-initially-hidden-parent.aspx.


    Kind regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. bharath
    bharath avatar
    23 posts
    Member since:
    Jun 2011

    Posted 02 May 2014 in reply to Jocelyn Link to this post

    Iam using Radeditor in aspx page. when i type some data in radeditor and try to get the content in button click event but not able to get the content.This problem is only happening in internetExplorer.But in Crome it working fine.when i added meta tag to make ie=8 then it works fine.pls let me know the problem in ie11. Iam using Vs2012

    /Bharath
  7. Joana
    Admin
    Joana avatar
    70 posts

    Posted 07 May 2014 Link to this post

    Hi Bharath,

    I am not able to reproduce the issue you have described. How do you get the content of the RadEditor? Please have a look at this article with topic Getting / Setting Content. I have tested the behavior in all IE and with latest version of Telerik UI for ASP.NET AJAX. What version are you using?

    Could you please isolate the issue and give us steps to reproduce it or send us a simple, fully runnable project so we will be able to reproduce and examine it locally on our side? You could open a support ticket if you don't want to share the content of your project

    Regards,
    Joana
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  8. Chad
    Chad avatar
    8 posts
    Member since:
    Feb 2014

    Posted 14 May 2014 Link to this post

    I'm using IE version 11.0.9600.16661

    You can view the RadEditor by navigating to this page: http://www.changeyourenergy.com/wellness-guide/1026/20140428-go-all-natural-for-healthier-skin-care and scrolling to the bottom.

    I've tried using the style sheet combination markup found here: http://www.telerik.com/forums/incorrect-rendering-of-radeditor-when-shown-with-ajax-in-initially-hidden-parent but it did not fix my problem. 

  9. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 16 May 2014 Link to this post

    Hello Chad,

    I am sorry, but the mentioned page requires a registration to show up the editor. 

    It would be more-helpful if you could try isolating the issue in a simple project and provide it for further investigation.

    On a side note, I suggest following this help article for further information on layout issues due to initially hidden RadEditor. 

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017