RadEditor is not working after updating telerik ajaxcontrol updation

2 posts, 0 answers
  1. Ankit
    Ankit avatar
    6 posts
    Member since:
    Dec 2012

    Posted 08 Jan 2013 Link to this post

    Hi,

    Earlier we were using this 3 dlls 2008.3.1314.35 (telerik.web.ui), 2008.3.1314.20 and radeditorsharepoint 5.3.2
    Now we are using latest telerik dll 2012.3.1205.35 and also previous dll, 2008.3.1314.20 as it is used by radeditorsharepoint 5.3.2.
    After doing this, Editor is not wokring. I am getting the UI but none of the command is working like copy paste everything.
    What could be the reason? Will new telerik dll 2012.3.1205.35 work with radeditorsharepoint 5.3.2. and we don't require  2008.3.1314.20
    dll?





    Thanks
  2. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 09 Jan 2013 Link to this post

    Hi,

    Each version of RadEditor for SharePoint is released and works with a specific version of Telerik.Web.UI.dll. You can find information in the attached readme.txt file. This means that you cannot use 5.3.2 with Telerik.Web.UI.dll version different from 2008.3.1314 without risking to break the control or some of it features.

    Note that the development of RadEditor for MOSS is discontinued and it does not officially support version 2012.3.1205.35 of RadEditor for ASP.NET AJAX. You can see this blog post for more information: RadEditor for MOSS (SharePoint 2007) Discontinued as of Q2 2012.

    My suggestion is to upgrade to the latest official build of RadEditor for MOSS 5.8.16 which comes with Q2 2012 of RadControls for ASP.NET AJAX.

    All the best,
    Rumen
    the Telerik team

    Consider using RadControls for ASP.NET AJAX (built on top of the ASP.NET AJAX framework) as a replacement for the Telerik ASP.NET Classic controls, See the product support lifecycle here.


Back to Top