RadEditor for lists has very small content area

3 posts, 0 answers
  1. mtjohnson
    mtjohnson avatar
    2 posts
    Member since:
    Jul 2007

    Posted 03 Jul 2007 Link to this post

    I'm trying out Lite RadEditor for MOSS on my WSS3 site to edit lists. Followed the instructions in help and everything went super-smoothly and it was up and running in minutes (kudos telerik!)

    My only problem is that when I click Edit on a list item, for example a wiki page, the content area is really small in both IE and Firefox. If I'm trying to edit a large wiki page this is a significant problem.

    Wondering if it is possible to make the window larger, or better yet have it expand to fill available space. Can I edit the CSS to do this?

    Mike J.
  2. Lini
    Lini avatar
    2144 posts

    Posted 04 Jul 2007 Link to this post


    You can control the editor size by modifying the ListConfigFile.xml file in \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\\RadControls\Editor\ on your server.

    Currently the width and height are set to the following:

      <property name="Height">240px</property>
      <property name="Width">500px</property>

    you can increase these values or you can experiment with percent values (e.g. 100%) and see if the editor will stretch to fill the available space.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. mtjohnson
    mtjohnson avatar
    2 posts
    Member since:
    Jul 2007

    Posted 05 Jul 2007 Link to this post

    Thanks Lini, that did the trick.

    I found that setting width to 100% results in a reasonably-sized window, but it's still a little small because one of the container divs somewhere seems to have a fixed width. One could probably hunt it down in the HTML source and maybe tweak the SharePoint form but it ends up being a lot of time for one small issue. Easier to set it to 800px and call it a day :)

    Setting the height to a percentage results in a zero-height editing area.
     "Auto" does not work and generates an error.

Back to Top