RadEditor Display Issue in FireFox 2.0.0.11

12 posts, 0 answers
  1. Brandon Worrell
    Brandon Worrell avatar
    9 posts
    Member since:
    Dec 2007

    Posted 08 Jan 2008 Link to this post

    When I view the "Prometheus" version of the RadEditor in FireFox 2.0.0.11, it has a display issue. There is a bunch of garbage appearing above the toolbars (looks like a bunch of tool bar end caps in two long rows) and there's an extra gray bar tacked on to the bottom of the editor window. You can see screen shots here:

    Screen shot one
    Screen shot two

    This happens both when I install and utilize the editor myself and when I view the RadEditor on the Telerik site with FireFox. I thought it might be Addons, so I disabled them all, but the issue persists.

    Any ideas what's up?
    Thanks
  2. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 08 Jan 2008 Link to this post

    Hi Brandon,

    This looks like a browser caching issue.

    Could you please press Ctrl+F5 and see whether this will fix the problem? You should also delete your browser cache.

    If the problem still persists please open a support ticket and send a sample working project that demonstrates the problem. I will examine it and try to provide a solution.


    Greetings,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Petio Petkov
    Admin
    Petio Petkov avatar
    825 posts

    Posted 08 Jan 2008 Link to this post

    This is a quick follow-up, Brandon!

    Probably you have manually changed your Minimum Font Size in Firefox. Please go to :
    Tools -> Options -> Fonts&Colors -> Advanced -> Set the "Minimum Font Size" to None .

    If this doesn't help you, please send us a screenshot of your "firefox fonts" dialog.


    Best regards,
    Petio Petkov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. Brandon Worrell
    Brandon Worrell avatar
    9 posts
    Member since:
    Dec 2007

    Posted 08 Jan 2008 Link to this post

    My minimum font size was set to 10. I changed it to None and that fixed the display issue. Thanks!
  6. Jeff Keys
    Jeff Keys avatar
    4 posts
    Member since:
    May 2003

    Posted 19 Jan 2008 Link to this post

    FWIW I ran into the same problem - I do not believe that I manually change the min font size but in any case setting it to none fixed the problem - you might consider including this in the RadEditor docs - I only found this solution after a quite a few searches
  7. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 20 Jan 2008 Link to this post

    Hi Jeff,

    Thank you for your suggestion!
    I will include this issue and the solution in the editor's documentation.


    Kind regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. Dave
    Dave avatar
    12 posts
    Member since:
    Mar 2008

    Posted 28 Mar 2008 Link to this post

    Are there any plans to actually fix this bug?  Unfortunately asking visitors/customers to change their browser settings is not professional.  It seems that all skins suffer from it as well.  Please let me know, thanks.

    -Dave
  9. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 28 Mar 2008 Link to this post

    Hi Dave,

    Thank you for your suggestion. I logged the issue in our bug tracking system and if possible our developers will fix it in one of the upcoming versions of the control.

    For the time being my suggestion is to use the "Tools -> Options -> Fonts&Colors -> Advanced -> Set the 'Minimum Font Size' to None" solution.

    Best regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  10. dmbandme
    dmbandme avatar
    6 posts
    Member since:
    Apr 2007

    Posted 26 Aug 2008 Link to this post

    I don't know if there has been any change in this thread, but I have the same scenario and it's impractical for me to ask every user to go in to their firefox settings to turn off the minimum font size. Looking at the HTML of my page I think the problem is the wrapper around the editor that was coded to add the rounded corners / top and bottom edge. It's done with tables, and the problem is the   inside the table table cells. 

    I hope Telerik fixes this, I know there are quite a few cross-browser ways of adding rounded corner wrappers and firefox is an important brownser to support.

    In the meantime I effectively turned off the problem areas with the following css (default skin):

    <style type="text/css">

    .rade_corner_top_left, .rade_center_top, .rade_corner_top_right
    {
        display: none;
    }

    .rade_corner_bottom_left, .rade_center_bottom, .rade_corner_bottom_right
    {
        display: none;
    }

    </style>

    Anyone else have a better solution?

    --Aaron
  11. Martin
    Admin
    Martin avatar
    585 posts

    Posted 27 Aug 2008 Link to this post

    Hello,

    Unfortunately, at this stage we are not able to control the zoom and min font-size of the browsers, as these are system settings that cannot be changed with CSS or JavaScript.

    The rounded corners of RadEditor consist of table cells with a &nbsp; inside, which is in fact a symbol. That is why when you are using certain browser settings such as font-size a cell dislocation occurs. On the other hand, we cannot remove the &nbsp, because having empty cells on a page triggers another two problems - empty elements is not xhtml compliant and empty cells cause a number of other issues, as the empty-cells property is not implemented correctly in any browser.

    What I can suggest here is to keep using the fix you have invented, but, please have in mind that the usage of the zoom and font settings in the browsers is really rarely used.

    Best wishes,
    Martin Ivanov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  12. dmbandme
    dmbandme avatar
    6 posts
    Member since:
    Apr 2007

    Posted 27 Aug 2008 Link to this post

    Hi Martin,

    Today I found another temporary fix for this, I know generally why it works and I've tested in IE 7, FF3, and Safari. Only Safari looks a little off, but generally pretty good. It's simply this:

    <style type="text/css">

    #editorWrapper td
    {
        font-size: 9px;
    }

    </style>

    Martin,

    I'd like to preface my comment by saying that generally I've been very happy with the Telerik suite. For the price, you get so much right out of the box and I've used the controls in many scenarios that have more than covered the price tag and generally work great and saved me alot of time. There are some very smart  and dedicated folks turning out release after release and I'm usually very impressed.

    Also, I do want to say that I understand Telerik, nor anyone else can change / manipulate a browser's minimum font size / zoom control. Zoom I'd say don't worry about it, most site layouts break when a brower arbitrarily increases the font / image sizes.

    However, the 10px minimum font size on firefox is very well known and not going anywhere as far as I've heard. Even though I agree Mozilla shouldn't be setting this to the default, they are, so my website and your controls should probably be written in a way that gets around this. It's impractical to ask users on a public site to go in to their browser settings before viewing your page.

    What I generally expect from the Telerik controls is that I can confidently drop a control, (usually with all default settings set) onto a page and not have to worry about it looking right / functioning right in all major browsers / platforms. The corners have background images which are shifted and so you're only trying to show 3px squared of that background image in the cell, firefox forces 10px so it looks bad, I get that. But there are ways around this scenario (see screenshots in first post of the problem). Your non-prometheus version of this control didn't have this issue which I'm assuming came as a result of a different structure of skin CSS classes.

    I hope the next release of the controls have a fix for firefox because it's been a while that this has existed and my fix isn't really a fix but a hack.

    Thank you Telerik, keep up the good work and thanks for your product. Again, I'm overall a very happy customer.
    --Aaron
  13. Martin
    Admin
    Martin avatar
    585 posts

    Posted 28 Aug 2008 Link to this post

    Hello Aaron,

    Thanks for your email and for the solution you gave. Please, be patient. I believe that we will find a rock solid fix for this issue and it will come with the next major release.

    Have a great day,
    Martin Ivanov
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017