RadDocking Unpin state - Unable to see full content on mouse over , width issue

6 posts, 1 answers
  1. Shilpa
    Shilpa avatar
    12 posts
    Member since:
    Mar 2013

    Posted 22 Jul 2013 Link to this post

    Hi !, Following XAML shows implementation,

    <telerik:RadDocking x:Name="radDock"  BorderThickness="0" Padding="0" AllowUnsafeMode="True" HasDocumentHost="False"
                                ShowResizePreview="False" MouseLeftButtonUp="radDock_MouseLeftButtonUp">
                <telerik:RadSplitContainer InitialPosition="DockedRight" MinWidth="200" MaxWidth="200">
                    <telerik:RadPaneGroup x:Name="toolBoxradPaneGroup">
     
                        <telerik:RadPane Name="pan" Header="{Binding Path=LocalizedStrings.Toolbox,Source={StaticResource ResourceObj}}" CanUserClose="False" CanFloat="False"
                                   ContextMenuTemplate="{x:Null}" AutoHideWidth="200">
     
                            <telerik:RadPane.Content >
                                <Grid>
                                    <Grid.RowDefinitions>
                                        <RowDefinition Height="Auto"></RowDefinition>
                                        <RowDefinition Height="*"></RowDefinition>
                                    </Grid.RowDefinitions>
                                  <!-- toolkit:Accordion data goes here -->
                                   </Grid>
                            </telerik:RadPane.Content>
                        </telerik:RadPane>
                    </telerik:RadPaneGroup>
                </telerik:RadSplitContainer>
            </telerik:RadDocking>

    my problem is shown in attached screen shot. please help to fix this issue.

    a not acceptable workaround to this is giving  MinWidth="250" to telerik:RadDocking. But this is creating in more issue.
  2. Rosen Vladimirov
    Admin
    Rosen Vladimirov avatar
    640 posts

    Posted 24 Jul 2013 Link to this post

    Hello Shilpa,

    It looks like you have placed RadDocking control in a Grid Column with Width="Auto". When you unpin the pane, RadDocking is resized and its size is very low. As the height of the Grid's Column  is set to Auto, it automatically shrinks the space for it and the other columns take this place. When you move the mouse over the unpinned pane, it is shown in the maximum allowed size, which is the current size of RadDocking control. Setting AutoHideWidth of RadPane is working only when its value is lower than RadDocking's width.
    So the solution here is to set a width for your column (for example it can be 200, based on your code).

    Hopefully this helps. Feel free to contact us in case you have any problems or concerns.

    Regards,
    Rosen Vladimirov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft banner
  4. Shilpa
    Shilpa avatar
    12 posts
    Member since:
    Mar 2013

    Posted 24 Jul 2013 Link to this post

    Hi Rosen,

    Thank you for reply. as in mentioned in my note, giving a width to grid column is giving me static area to RadPane which i don't want. [Please see the attached file for o/p i received]

    One of my senior said that we changed the version of telerik dll and then this issue raised because one old version of solution is not giving this issue. Is that can be a case ?

  5. Shilpa
    Shilpa avatar
    12 posts
    Member since:
    Mar 2013

    Posted 24 Jul 2013 Link to this post

    attached file for both old and new dll versions details. Please let me know if the issue is of DLL version
  6. Shilpa
    Shilpa avatar
    12 posts
    Member since:
    Mar 2013

    Posted 26 Jul 2013 Link to this post

    Hi 

    I found the property "ConstraintAutoHideArea="False" " which fixed my problem.

    Thanks. [How to mark this post as Answered ?]
  7. Answer
    Rosen Vladimirov
    Admin
    Rosen Vladimirov avatar
    640 posts

    Posted 26 Jul 2013 Link to this post

    Hello Shilpa,

    I'm glad you have found a solution. In order to mark the thread as answered, you have to mark one of the posts as Answer (check attached image).

    Please note that we do not recommend usage of AllowUnsafeMode="True".

    Feel free to contact us in case you have any other problems or concerns.

    Regards,
    Rosen Vladimirov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
Back to Top
DevCraft banner