RadDocking, DocumentHost and OverflowMode not working

4 posts, 1 answers
  1. WILLIAM
    WILLIAM avatar
    134 posts
    Member since:
    Jun 2012

    Posted 16 Nov 2011 Link to this post

    I am using Telerik's Silverlight Control suite to build a tabbed view. I'm using the RadDocking control, and specifically the DocumentHost to contain a RadPaneGroup. My problem is that the RadPane inside of this RadPaneGroup scaling the tab label (where the text is), rather than showing the tab label at it's full width. This happens when the RadPaneGroup is made small enough (horizontally), to the point that all the tab labels no longer fit across. My preference in this case would be to have the tab labels remain at their maximum width, and see the tab labels scroll instead. I've see a few references to this behavior, and the solution seems to bemake the OverflowMode="Scroll". I've done this (see attached XAML snippet), to no avail. Am I missing something?
    Thanks for any help.

        <Grid x:Name="LayoutRoot" Background="White">
            <telerikDocking:RadDocking Name="uxRadDocking" Grid.Row="0">
                <telerikDocking:RadDocking.DocumentHost>
                    <telerikDocking:RadSplitContainer>
                        <telerikDocking:RadPaneGroup Name="uxMainTabs" ScrollMode="Item" OverflowMode="Scroll"/>
                    </telerikDocking:RadSplitContainer>
                </telerikDocking:RadDocking.DocumentHost>
                <telerikDocking:RadSplitContainer InitialPosition="DockedBottom" Height="100">
                    <telerikDocking:RadPaneGroup Name="uxValidation"/>
                </telerikDocking:RadSplitContainer>
                <telerikDocking:RadSplitContainer InitialPosition="DockedTop" Height="60">
                    <telerikDocking:RadPaneGroup Name="uxHeader"/>
                </telerikDocking:RadSplitContainer>
                <telerikDocking:RadSplitContainer InitialPosition="DockedRight" >
                    <telerikDocking:RadPaneGroup Name="uxFlyOut"/>
                </telerikDocking:RadSplitContainer>
            </telerikDocking:RadDocking>
        </Grid>
    </UserControl>

  2. Chuck
    Chuck avatar
    10 posts
    Member since:
    Sep 2012

    Posted 16 Nov 2011 Link to this post

    I've seen this same behavior. I've also been through all the samples, and they seem to all behave this way. I'm interested in what you find out.
  3. DevCraft banner
  4. Answer
    Miroslav Nedyalkov
    Admin
    Miroslav Nedyalkov avatar
    1718 posts

    Posted 21 Nov 2011 Link to this post

    Hi Everybody,

    You need to set the ScrollViewer.HorizontalScrollBarVisibility to Auto to the PaneGroup to enable this behavior. It is switched off by default.

    Hope this helps.

    Regards,
    Miroslav Nedyalkov
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  5. WILLIAM
    WILLIAM avatar
    134 posts
    Member since:
    Jun 2012

    Posted 21 Nov 2011 Link to this post

    That did the trick, thanks.
Back to Top