RadDocking and iiyama touchscreen

5 posts, 1 answers
  1. david
    david avatar
    25 posts
    Member since:
    Oct 2008

    Posted 08 Jan 2013 Link to this post

    Hi guys,

    I have a strange problem, I'm using the telerik wpf docking controls version 2012.3.1203.40 with VS2012 when my touchscreen is connected to my pc by USB (touchscreen: iiyama prolite T2250MTS) the RadDockingAutomationPeer throw an nullreference exception on loading.
    If the touchscreen is not connected everything works just fine.

    I tried to create a testproject for you, but the testproject throws an ArgumentNullException in the RadTabControlAutomationPeer, in this project I'm not using the RadTabControl.
    And again if the touchscreen is not connected everything works fine.

    The workaround is easy, just disconnect the touchscreen :-). For now this is my workaround, but it is no solution

    Can you check it out?

    How do I upload my test project?

    David.
  2. Georgi
    Admin
    Georgi avatar
    349 posts

    Posted 11 Jan 2013 Link to this post

    Hi David,

    As the RadDocking uses internally TabControl, the exception occurs in the project, nevertheless it should be fixed in the Last Internal Build. You can downloaded from our website and give it a try.
    Also in order to send us the simple project you have prepared you just need to open a new support ticket and attached the project in it.
    As we are not aware of the issue with the RadDockingAutomationPeer it would be great if you can also give us a simple steps to reproduce.

    Greetings,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. UI for WPF is Visual Studio 2017 Ready
  4. david
    david avatar
    25 posts
    Member since:
    Oct 2008

    Posted 16 Jan 2013 Link to this post

    Hi Georgi ,

    I downloaded the latest version as you mentioned in your reply and upgraded my testproject

    I have a lot less problems now, it seems to be working......

    but when I set a debug exception on System.NullReferenceException it still throws an exception.


    When I start the executable it does not show any errors.
  5. Answer
    Georgi
    Admin
    Georgi avatar
    349 posts

    Posted 17 Jan 2013 Link to this post

    Hello David,

    Thank you for the clarification.
    We were able to reproduce the exception and I am glad to inform you that it was recently fixed. The fix available in the Latest Internal Build  (2012_3_1314). So it would be great if you can give it a try and let us know if everything is working as expected. 
    If you have any questions, please don't hesitate to write us.

    Regards,
    Georgi
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  6. david
    david avatar
    25 posts
    Member since:
    Oct 2008

    Posted 18 Jan 2013 Link to this post

    Thanks guys, I downloaded the latest version and upgraded my project and everything works!

    great job.
Back to Top
UI for WPF is Visual Studio 2017 Ready