Raddatepicker localization delay on page load

3 posts, 0 answers
  1. Ricardo
    Ricardo avatar
    2 posts
    Member since:
    Jul 2012

    Posted 16 Jul 2012 Link to this post

    Hi,

       I have recently upgraded telerik to version 2012.1.411.35, from 2009.3.1314.35. I have since encountered an issue with the Raddatepicker. When loading a page with a calendar control on it, the control initially seems to ignore the locale, showing a date format of YYYY-MM-DD-HH-MM-SS for 2-3 seconds, before adjusting itself to the proper format such as YYYY-MM-DD.

    We have implemented these using C#, running windows XP and IE8. The issue goes away if I revert back to telerik 2009, but we chose to upgrade to make use of the new telerik controls. I'd appreciate any help regarding this issue.

    Thanks,

    Ricardo Hernandez
  2. Vasil
    Admin
    Vasil avatar
    1547 posts

    Posted 19 Jul 2012 Link to this post

    Hello Ricardo,

    Set EnableSingleInputRendering="false" for the DateInput of your picker, or upgrade to 2012 Q2 version of the controls to resolve the problem.

    All the best,
    Vasil
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Ricardo
    Ricardo avatar
    2 posts
    Member since:
    Jul 2012

    Posted 19 Jul 2012 Link to this post

    Thanks for the reply Vasil. I got it to work yesterday by upgrading to 2012 Q2. It's really good to know there is also another workaround.
Back to Top