RadDataGrid issue on Windows 10 Universal App

9 posts, 0 answers
  1. Abdulkhadar
    Abdulkhadar avatar
    5 posts
    Member since:
    May 2015

    Posted 20 May 2015 Link to this post

    Hi,

    We are facing issues with Telerik "RadDataGrid" on Windows 10 Universal App. The same code works fine for Windows 8.1 App on Windows 10 machine.

    Issues with RadDataGrid are:

    1) "Filter" and "Clear Filter Text" buttons text is corrupted in the filter pop up screen as shown in the attached screenshot "TelerikFilterIssue.png". Filter functionality works fine, issue is only with the buttons text being corrupted.

    2) "Sorting" symbol is not an arrow mark, it is displayed something like corrupted symbol as shown in the attached screenshot "TelerikSortingIssue.png".

     

    There is no issue with functionality of Telerik "RadDataGrid", only issue with the display.

     

    Thanks

    Abdul

  2. Vladislav
    Admin
    Vladislav avatar
    276 posts

    Posted 22 May 2015 Link to this post

    Hi Abdulkhadar,

    We are unable to reproduce the described behavior based only on the information provided.
    Is it possible to send us more information regarding your setup/project.

    What is the exact version of the operating system? The version of the VisualStudio 2015?
    Is your project a "Windows Universal" (UWP) or a "Windows 8.1" one?

    Is it possible to send us a sample project (or stripped version of your original one) in order to investigate it locally?

    Thank you in advance.

    Regards,
    Vladislav
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Abdulkhadar
    Abdulkhadar avatar
    5 posts
    Member since:
    May 2015

    Posted 25 May 2015 in reply to Vladislav Link to this post

    Thanks for the reply. Please find the below details about OS, Visual Studio and Telerik Version.

    I am not able to attach the same code to this post. Let me know how I can provide the code. Is it possible to have skype call and close on this.

    App: "Windows Universal(UAP)" for Windows 10

    Operating System: Windows 10 (10074 build)

    Visual Studio 2015 RC, Version 14.0.22823.1 D14REL

    Telerik Grid Control Version: 2013.3.1105.45

    The same code works fine on Windows 8.1 app on windows 8.1 machine. We are planning to upgrade the app to windows 10 UAP, but the facing which mentioned.  

    Thanks

    Abdul  

  4. Abdulkhadar
    Abdulkhadar avatar
    5 posts
    Member since:
    May 2015

    Posted 25 May 2015 in reply to Abdulkhadar Link to this post

    Just attaching the xaml part where telerik grid binding is done.

    Also attaching solution structure.

  5. Vladislav
    Admin
    Vladislav avatar
    276 posts

    Posted 28 May 2015 Link to this post

    Hi Abdulkhadar,

    Thank you for the information provided.

    Our "UI for Windows Universal" suite currently does not support "Windows Universal(UAP)" for Windows 10 out of the box, although it may be possible to use it. We are going to release a suite targeting this platform after our 2015 Q2 official release (which is due end of June).

    Please note that the version of our controls you are using is quite outdated and we strongly recommend to try our recent releases for "UI for Windows Universal". Is it possible to give it a try and let us know the result?


    Regards,
    Vladislav
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Abdulkhadar
    Abdulkhadar avatar
    5 posts
    Member since:
    May 2015

    Posted 28 May 2015 in reply to Vladislav Link to this post

    Thanks for the reply. Let me know which version of Telerik Grid control would you like me to try.
  7. Vladislav
    Admin
    Vladislav avatar
    276 posts

    Posted 29 May 2015 Link to this post

    Hi Abdulkhadar,

    You can try our Q1 2015 official release (version "Telerik_UI_for_WindowsUniversal_2015.1.226.45") or the latest available internal build.

    Regards,
    Vladislav
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  8. Vladimir
    Vladimir avatar
    1 posts
    Member since:
    May 2014

    Posted 22 Jan Link to this post

    2) "Sorting" symbol is not an arrow mark, it is displayed something like corrupted symbol as shown in the attached screenshot "TelerikSortingIssue.png".

    This problem is not fixed in the latest build for UWP (DataGrid beta).

    It's very very strange, because the bug is too explicit and any tester saw it immediately.

  9. Vladislav
    Admin
    Vladislav avatar
    276 posts

    Posted 27 Jan Link to this post

    Hi Vladimir,

    Thank you for contacting us.
    We are aware of this (and several other "missing symbol") problems with our controls in UWP. They are logged and we will do our best to include a fix for it in some of our future releases.

    Your Telerik points are updated accordingly.

    Regards,
    Vladislav
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top