RadDataBoundListBox item not properly aligned (random behaviour) after adding to ObservableCollection

6 posts, 0 answers
  1. Olu
    Olu avatar
    10 posts
    Member since:
    Dec 2010

    Posted 20 Feb 2012 Link to this post

    I'm having problem with RadDataBoundListBox such that when I add/updated the associated ObservableCollection, the UI/view is updated with the new item but the item is randomly aligned, that is, default alignment is 'Left', when I add new items sometimes it aligns 'Right', sometimes 'Center', other times 'Left' or even a random left-margin.

    If I exit the application and re-launch, everything shows correctly. But adding/updating at run-time results in this random behaviour.

    If I change the RadDataBoundListBox to a standard WP ListBox control, I do not have the same problem at all.

    Any ideas why this is happening? Thanks.
  2. Deyan
    Admin
    Deyan avatar
    2041 posts

    Posted 20 Feb 2012 Link to this post

    Hi Olu,

    I would like to inform you that we are aware of similar issue that happens when adding items to the source collection of RadDataBoundListBox when the control is unloaded, i.e. when you have navigated to a page different from the one that has the listbox. We will provide a fix for this issue in Q1 2012 SP1 and also will release an Internal Build containing this fix soon.

    Could you please confirm that the scenario mentioned above is the one that causes the issue on your side? If you think this is not the case, it will be great if you manage to reproduce the issue in a separate WP project and send it to us for further investigation.

    Please note that you will have to open a new support ticket in order to be able to attach your project.

    Regards,
    Deyan
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  3. DevCraft banner
  4. Olu
    Olu avatar
    10 posts
    Member since:
    Dec 2010

    Posted 20 Feb 2012 Link to this post

    I think this might be the same issue because all the views with the DataBoundListBox has the corresponding addiing pages on a separate page. I think I'll be able to confirm by making the addition on the same page and see if issue occurs.

    Any timelines on teh Q1 2012 SP1?

    Thanks.
  5. Deyan
    Admin
    Deyan avatar
    2041 posts

    Posted 20 Feb 2012 Link to this post

    Hello Olu,

    Normally, the Service Pack comes a month after the official release.

    Regards,
    Deyan
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  6. John
    John avatar
    7 posts
    Member since:
    Nov 2011

    Posted 13 Mar 2012 Link to this post

    Has this fixed been released yet. I am seeing similar behavior on the RadJumpList which inherits from RadDataBoundListBox. Thanks.
  7. Deyan
    Admin
    Deyan avatar
    2041 posts

    Posted 14 Mar 2012 Link to this post

    Hi John,

    Yes, our latest internal build has been released and you should be able to download it from the Downloads section of your Telerik account.

    Note that an IB represents the current development state of the suite and has not been entirely tested according to our QA procedures.

    Let me know in case you have further questions or need assistance.

    Kind regards,
    Deyan
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Back to Top
DevCraft banner