RadCaptcha image not showing

4 posts, 0 answers
  1. JJ
    JJ avatar
    147 posts
    Member since:
    May 2010

    Posted 28 Jun 2010 Link to this post

    I use RadCaptcha on a email page that does not require the user to login to the site to finish - used <allow users="*"/> in web.config for this email.aspx location.

    But the rest of the pages on site need the user to login - put under secured direct.
     
    When I go to the email.aspx, I can see everything on the email pages, except the RadCaptcha image.

    How I resove this problem?

    Thanks!

    Jessie
  2. Pero
    Admin
    Pero avatar
    1156 posts

    Posted 30 Jun 2010 Link to this post

    Hi Jessie,

    "Forms" authentication requires a registered user to be logged-in to the system in order to access a certain resource or a given page. If the user is not logged-in and tries to access a resource that requires a log-in (such as the RadCaptcha httpHandler in your case), he/she is redirected to the Login page. That is why the image is not shown, because it requires log-in.

    To solve this problem you should use the <location> Element to specify different authentication settings for the RadCaptcha httpHandler. Please use similar code for your application as the one shown below, and if you have any problems, please send us a sample project that demonstrates the issue. We would be glad to help.

    1.
    <location path="Users_Management/Pages/CreateUser"
        <system.web
          <authentication mode="None"/>
        </system.web
    </location>

    <location path="Telerik.Web.UI.WebResource.axd">
      <system.web>
        <authentication mode="None"></authentication>
      </system.web>
    </location>

    or
    2.
    <location path="Users_Management/Pages/CreateUser">
        <system.web>
          <authorization>
              <allow users="*"/>
          </authorization>
        </system.web>
    </location>

    <location path="Telerik.Web.UI.WebResource.axd">
      <system.web>
        <authorization>
          <allow users="*"/>
        </authorization>
      </system.web>
    </location>


    Kind regards,
    Pero
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Prakash
    Prakash avatar
    2 posts
    Member since:
    Oct 2012

    Posted 06 Sep 2012 Link to this post

    Hi,
     I am facing the similar issue with rad captcha, I have configured Form based authentication in one of the sharepoint 2010 application and included rad captcha in login control  and did all settings in web.config including above mentioned.
    but when i am accessing the login page captcha is not rendering.
    where as its working perfectly fine in asp.net application.

    can i know what are the seetings required to work in sharepoint 2010.

    Regards
    Prakash Patil







  5. Slav
    Admin
    Slav avatar
    1356 posts

    Posted 10 Sep 2012 Link to this post

    Hi Prakash,

    I would suggest checking if the RadCaptcha httpHandler is registered in your Sharepoint project as shown in this help article.

    Since you are using authentication, you also need to allow access to the RadCaptcha httpHandler to all users. This is shown in the following code snippet:
    <location path="Telerik.Web.UI.WebResource.axd">
        <system.web>
            <authorization>
                <allow users="*"/>
            </authorization>
        </system.web>
    </location>

    I noticed that you have reported the same problem in this forum thread. Please use a separate thread for this purpose in the future as the information on the case will be easier to track.

    All the best,
    Slav
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top