Radbutton is cut in sharepoint 2013 Visual webpart

4 posts, 1 answers
  1. Kishor
    Kishor avatar
    82 posts
    Member since:
    Oct 2012

    Posted 26 Jun 2014 Link to this post

    hello

    I am using telerik radbutton in sharepoint 2013  (visual webpart )


    but the buttons are cut as shown it attached image.

    also no other skin except default skin apply for the radgrid  otherwise it gives error.


    please give some solution

    thanks
    kishor
  2. Answer
    Danail Vasilev
    Admin
    Danail Vasilev avatar
    1492 posts

    Posted 30 Jun 2014 Link to this post

    Hi Kishor,

    This is a known issue with SharePoint 2013 that applies global styles on inputs. The issue has already been logged here, so that you can monitor, comment and vote on it. For the time being you can use the CSS workaround provided in the item.

    Regarding the issue with the RadGrid I can suggest that you open a separate forum thread/support ticket for the RadGrid control and provide more details there.

    Thank you for your cooperation.

    Regards,
    Danail Vasilev
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Kishor
    Kishor avatar
    82 posts
    Member since:
    Oct 2012

    Posted 30 Jun 2014 in reply to Danail Vasilev Link to this post

    In sharepoint 2013 webpart no skins other than Default  applies for radgrid

    I have included Telerik.web.skins in package and also in bin folder ,but still it does not work

    please help
  5. Danail Vasilev
    Admin
    Danail Vasilev avatar
    1492 posts

    Posted 02 Jul 2014 Link to this post

    Hi Kishor,

    We are not aware of the mentioned issue with RadGrid's Skins in SharePonint 2013.

    What I can suggest is that you try the following troubleshooting steps:
       - If you are not using the latest official version of Telerik UI - 2014.2.618, does upgrading to it fixes the issue?
       - In order for Telerik UI controls to work properly the version of all of the .DLL files (i.e., Telerik.Web.UI.dll, Telerik.Web.UI.Skins.dll and Telerik.Web.Design.dll) must match. Can you ensure that?
       - The obsolete built-in skins Transparent, Hay, Forest and Sitefinity have been removed from the Telerik.Web.UI.Skins assembly as of the Q1 2014 release of Telerik UI for ASP.NET AJAX. More information on the matter is available in the release notes (see the All Controls section) Q1 2014 and this sticky note (scroll to the bottom of the page). Can you ensure that you are not using these skins?

    If the above steps, however, do not help it would be better to provide us with the problematic Visual Web Part, so that we can make an investigation locally. Could you also tell us what is the error message that is thrown?

    Regards,
    Danail Vasilev
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top