RadBusyIndicator react too late

2 posts, 0 answers
  1. Gyula
    Gyula avatar
    8 posts
    Member since:
    Oct 2010

    Posted 14 Dec 2011 Link to this post

    Dear Support!

    I am using RadControls_for_WPF_2011_3_1205_DEV_hotfix.

    When I set RadBusyIndicator.IsBusy="True" and operating system is running a cpu hungry process, I can click on the RadBusyIndicator content before RadBusyIndicator show busy content (refer attachment).

    Please let me know how to resolve the issue.

    MainWindow.xaml
    <Window x:Class="RadBusyIndicatorDemo.MainWindow"
            Title="MainWindow" Height="350" Width="525" WindowStartupLocation="CenterScreen">
         
        <StackPanel>
            <TextBlock x:Name="textBlock" />
            <telerik:RadBusyIndicator IsBusy="True">
                <StackPanel>
                    <Button Content="Button1" Click="Button_Click"/>
                    <telerik:RadGridView ItemsSource="{Binding Items}" Height="300" />
                </StackPanel>
            </telerik:RadBusyIndicator>
        </StackPanel>
    </Window>


    MainWindow.xaml.cs
    namespace RadBusyIndicatorDemo
    {
        public partial class MainWindow : Window
        {
            public MainWindow()
            {
                InitializeComponent();
     
                this.DataContext = new MainViewModel();
            }
     
            private void Button_Click(object sender, RoutedEventArgs e)
            {
                this.textBlock.Text = "clicked!"; // shouldn't happen
            }
        }
    }
  2. Ivo
    Admin
    Ivo avatar
    390 posts

    Posted 16 Dec 2011 Link to this post

    Hello Balázs,

    Setting the RadBusyIndicator property DisplayAfter to 0 will do the trick for you.

    Greetings, Ivo
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. UI for WPF is Visual Studio 2017 Ready
Back to Top