RadAsyncUpload does not have permission to write files in the TemporaryFolder

9 posts, 0 answers
  1. Sarah
    Sarah avatar
    19 posts
    Member since:
    Mar 2009

    Posted 08 Jul 2010 Link to this post

    I'm getting this error:


    RadAsyncUpload does not have permission to write files in the TemporaryFolder. In Medium Trust scenarios, the TemporaryFolder should be a subfolder of the Application Path.


    I have given Network Service full control of App_Data folder.  What am I missing?
  2. Genady Sergeev
    Admin
    Genady Sergeev avatar
    1596 posts

    Posted 09 Jul 2010 Link to this post

    Hello Sarah,

    Try adding permissions for the Authenticated_Users account too.

    Sincerely yours,
    Genady Sergeev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Sarah
    Sarah avatar
    19 posts
    Member since:
    Mar 2009

    Posted 09 Jul 2010 Link to this post

    I had to set full permissions for iis_iusrs
  5. Lenny_shp
    Lenny_shp avatar
    343 posts
    Member since:
    Jul 2006

    Posted 26 Jul 2010 Link to this post

    If the application is running under a specific ID in application pool is RadAsyncUpload using that app pool ID?

    (If I have impersonate=true in the web.config then it's using the current user's credential)

    This is for Intranet, I have to explicitly set Authenticated Users to have write access to App_Data.

    Can you add an attribute to RadAsyncUploadso it can be toggled to use the application pool credential if impersonate=true in web.config?    This way I do not have to explicitly add permission to the App_Data directory yet maintain impersonate=true.

    I don't want to code stuff in FileUploaded event but do final save when user submits.

                    Using Hosting.HostingEnvironment.Impersonate
                        file.SaveAs(default_app_data, True)
                    End Using
  6. T. Tsonev
    Admin
    T. Tsonev avatar
    2771 posts

    Posted 29 Jul 2010 Link to this post

    Hi Lenny,

    Thank you for the suggestion. Such property should be useful to a lot of customers.

    I've logged it into our Public Issue Tracking System where you can vote for it and track its progress.

    As a token of gratitude for your involvement your Telerik points have been updated.

    Greetings,
    Tsvetomir Tsonev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Josh
    Josh avatar
    1 posts
    Member since:
    Aug 2012

    Posted 09 Aug 2012 Link to this post

    I had similar issues - I ended up using the RadUpload control inside a radwindow as my company nor I liked the fact of explicitly adding permissions to the app_data folder (Just one more configuration for production builds). (windows authentication)
    The radwindow handles the page refresh just fine. If your impersonating a user, make sure to wrap the save, TargetPhysicalFolder, pretty much everything in your save event inside a token.  

    * Also make sure to clear the TargetPhysicalFolder path in somewhere like onprerender of the control. If you don't and your using windows authentication, your going to notice it tries to use the windows authenticated user the second time around as it's set now and the Event for attaching will not even fire. 

    You can use process monitor to help in permissions.

  8. Peter Filipov
    Admin
    Peter Filipov avatar
    1028 posts

    Posted 14 Aug 2012 Link to this post

    Hello Josh,

    We implemented a property which is called UseApplicationPoolImpersonation. It will help in the described cases. The new functionality will come with Q3.2012.

    Regards,
    Peter Filipov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  9. Cees
    Cees avatar
    4 posts
    Member since:
    Oct 2012

    Posted 19 Dec 2012 Link to this post

    Hello,

    Can you show me the syntax for setting UseApplicationPoolImpersonation and impersonate="true" in the web.config?

    The RadAsyncUpload is working on localhost (from visual studio) and in my external website (www.jmcsignmakers.nl) but not
    on my intranet site. 



  10. Peter Filipov
    Admin
    Peter Filipov avatar
    1028 posts

    Posted 20 Dec 2012 Link to this post

    Hi Cees,

    You need to set the UseApplicationPoolImpersonation property of the RadAsyncUpoad to true and set  from the identity section in the web.config impersonate property to true.
    Could you please clarify how the control is not working in your intranet environment? The file could not be uploaded or there is a javascript error on the page?

    Regards,
    Peter Filipov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017