Rad editor not working in firefox 3.0

11 posts, 0 answers
  1. chetali
    chetali avatar
    14 posts
    Member since:
    Aug 2008

    Posted 05 May 2009 Link to this post

    Hi,

    The Rad editor does not work in firefox 3.0.
    Do we the upgraded version available?
    The help doc that I got says Firefox 1.5 and 2.0 are supported.

    Regards,
    Chetali
  2. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 07 May 2009 Link to this post

    Hi Chetali,

    The Lite version of RadEditor for MOSS is based on RadEditor 7. I do not think that there will be any problem with it in FireFox 3.0.

    If there is something that is not working, please be more specific in describing it. Please inform us exactly which version of RadEditor for MOSS you are using. In what scenario (web part or forms such as list, wiki, blog ..)?

    Any additional information and a couple of screen shots will be helpful as well.

    Thank you.


    Regards,
    Stanimir
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.

  3. chetali
    chetali avatar
    14 posts
    Member since:
    Aug 2008

    Posted 08 May 2009 Link to this post

    Hi,

    We are using 4.5 version.
    The issue is we can not click in the RTE box in firefox.

    I dont see an option of attaching screen shots while replying to the posts.
  4. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 11 May 2009 Link to this post

    Hi Chetali,

    Could you please make sure that you extended your MOSS site with Microsoft ASP.NET AJAX correctly. You can find information on the matter in the following help articles.
    1. Extending your MOSS site with Microsoft ASP.NET AJAX 1.0 - for .NET 2.0
    2. Extending your MOSS site with Microsoft ASP.NET AJAX 3.5 - for .NET 3.5. In addition to the article make sure you add the following code to the web.config <runtime><assemblyBinding> section.
    <dependentAssembly> 
      <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35"/> 
      <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/> 
    </dependentAssembly> 
    <dependentAssembly> 
      <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35"/> 
      <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0"/> 
    </dependentAssembly> 


    I hope this helps.


    All the best,
    Stanimir
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  5. chetali
    chetali avatar
    14 posts
    Member since:
    Aug 2008

    Posted 11 May 2009 Link to this post

    I am not sure if I need this.

    Can you tell me if we have upgrade version of rad editor available which is supported in firefox 3.0 also.

    The help doc that we got clearly says that rad editor is supported in mozilla 2.0
  6. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 14 May 2009 Link to this post

    Hi Chetali,

    The steps described in my previous post are required if you were using RadEditor for MOSS v 5.x. I tested the latest version of the Light RadEditor for MOSS, which now is 4.5.6, in FireFox 3.0.10 web browser and it worked fine. There was no problems with it. So if you are having problems please upgrade to it.


    All the best,
    Stanimir
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  7. Henry
    Henry avatar
    1 posts
    Member since:
    Dec 2007

    Posted 25 Jun 2009 Link to this post

    Dear Support,

    Rad Editor MOSS Lite 4.5.6 doesn't work on Safari 4.0, FireFox 3.0 and Google Chrome 2.0.172.33

    I installed RadEditor MOSS lite 4.5.6 on 3 different SharePoint environments (MOSS and 2 WSS3). None of them works.
    I test it on a Blog Site and list (with RichText) on 4 different web browsers (IE, Safari, FireFox and Google Chrome).
    Only IE can publish content or Image in the Blog Post.
    Only IE can create new item in the List (with RichText)

    The following is what I did on my SharePoint.

    • Download this RadEditorMOSS_4_5_6.zip
    • Extending MOSS site with Microsoft ASP.NET AJAX 3.5 (http://www.telerik.com/help/aspnet-ajax/moss-install-aspnet-ajax-35.html)
    • add solution file(.wsp) to web app
    • activate feature on the site collection
    • Go to the Blog site by using IE, Safari, FireFox and Google Chrome.
    • Create a post >  At this point all of the above web browsers can see the RadEitior and I can use all of them to type content in the post. 
    • However, when I publish the content, ONLY IE can publish the content to the post. None of the web browsers(Safari, Firefox and Google) can publish all content. NOTE: When I click to publish the content to the post by using Safari, Firefox and Google. It publishes with nothing.
    • I also test it on image Manager (all of the above web browsers can upload images to the SharePoint site and can insert the image in the post
    • However, again Only IE can publish the image to post, Safari, FireFox and Google Chrome CAN NOT.

    Any help will be much appreciated

  8. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 01 Jul 2009 Link to this post

    Hi Henry,

    Unfortunately I was not able to reproduce the problem. For your convenience I attache a short movie with my test. Please inform me if I am doing any thing wrong. What you can do is providing us with a step by step scenario of how to reproduce the issue on our test server.

    Thank you.

    Greetings,
    Stanimir
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  9. Mandy
    Mandy avatar
    33 posts
    Member since:
    Mar 2010

    Posted 16 Jun 2010 Link to this post

    Dear Support,

                   i am using radEditor in my firefox but it gives some error in the error consol of the firefox and i am not able to Edit in radeditor.

    this error occur in error consol
    (Error: uncaught exception: [Exception... "An invalid or illegal string was specified"  code: "12" nsresult: "0x8053000c (NS_ERROR_DOM_SYNTAX_ERR)"  location: "http://localhost:4195/Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=RadScriptManager1_TSM&compress=1&_TSM_CombinedScripts_=%3b%3bSystem.Web.Extensions%2c+Version%3d1.0.61025.0%2c+Culture%3dneutral%2c+PublicKeyToken%3d31bf3856ad364e35%3aen-US%3a1f0f78f9-0731-4ae9-b308-56936732ccb8%3aea597d4b%3ab25378d2%3bTelerik.Web.UI%2c+Version%3d2010.1.309.20%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3aen-US%3a9da721b2-6765-4380-90c1-dafaf052b1d7%3a16e4e7cd%3af7645509%3a24ee1bba%3ae330518b%3a1e771326%3ac8618e41%3a8e6f0d33%3a6a6d718d%3aed16cbdc Line: 5213"])

    please help me with this ASAP.

    Thanks.
  10. Stanimir
    Admin
    Stanimir avatar
    1653 posts

    Posted 16 Jun 2010 Link to this post

    Hello Mandeep ,

    Could you confirm, which version of RadEditor for MOSS are you using? Is it the Light 4.5.6 version of the control or the Full ASP.NET AJAX 5.x one?

    Greetings,
    Stanimir
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  11. Mandy
    Mandy avatar
    33 posts
    Member since:
    Mar 2010

    Posted 06 Sep 2010 Link to this post

    Hello Admin,

                     Thanks for replying i got my problem solved .and i am very happy with your support.

    thanks again.

Back to Top