RAD Editor for MOSS Installation problem (doesnt show up)

6 posts, 0 answers
  1. B
    B avatar
    1 posts
    Member since:
    Jan 2009

    Posted 21 Jan 2009 Link to this post


    Last week i installed RadEditorMOSS_5_3_1_Dev in our sharepoint environment. I followed the steps describe in http://homercles.wordpress.com/2008/06/30/installing-telerik-moss-editor/.

    1: install ASP.Net Ajax Extensions
    2: Extending SharePoint web.config files with Microsoft ASP.NET AJAX 1.0
    3: Add RadEditorMOSS_5_3_1_Dev solution to sharepoint
    4: IIS Reset

    I did not add a ScriptManager into a SharePoint MasterPage.

    My question is:
    - Why is the standard sharepoint editor not replaced by the RAD Editor?
    - What do i need to do to accomplish this?

    Kinds regards

  2. Georgi Tunev
    Georgi Tunev avatar
    7207 posts

    Posted 21 Jan 2009 Link to this post

    Hello B,

    In our online help you can find the following articles. They explain how to use RadEditor for MOSS in different SharePoint scenarios.
    1.    Using the RadEditor WebPart http://www.telerik.com/help/aspnet-ajax/using-radeditor-webpart.html
    2.    Using RadEditor in List Items http://www.telerik.com/help/aspnet-ajax/using-radeditor-in-list-items.html
    3.    Using RadEditor in Web Content Management scenario http://www.telerik.com/help/aspnet-ajax/using-radeditor-in-web-content-management-scenario.html

    I think that you will find these articles helpful.

    Georgi Tunev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. DevCraft R3 2016 release webinar banner
  4. NLV
    NLV avatar
    87 posts
    Member since:
    Aug 2009

    Posted 26 Aug 2009 Link to this post

    Hello team,

    We've a full licensed telerik controls for ASP.NET ajax applications. I've used the RadEditor in my asp.net applications before. But can't i use the same control in a MOSS publishing site page? I've added the safe control for telerik.web.ui and i've also added the tag prefix in the page. But i'm getting unknown error. Can't i use Telerik.web.UI.RadEditor in my moss page?

  5. NLV
    NLV avatar
    87 posts
    Member since:
    Aug 2009

    Posted 26 Aug 2009 Link to this post

    Silly. Got it worked. I missed the ScriptManager.
  6. rajesh nagaboina
    rajesh nagaboina avatar
    4 posts
    Member since:
    Oct 2009

    Posted 06 Oct 2009 Link to this post

    I deployed Radeditor solutions in my sharepoint site.Ctivated the feature "" in the site features.
    Restarted the iis.
    when I trying to create new task list, comments textbox is disabled and I am unable to enter anything in that.

    I fallowed http://www.telerik.com/help/aspnet-ajax/using-radeditor-in-list-items.html  this link to do that........

    could you please help me ion this issue....
  7. Stanimir
    Stanimir avatar
    1653 posts

    Posted 09 Oct 2009 Link to this post

    Hello rajesh,

    If you are using the ASP.NET AJAX version of the control 5.x, make sure that you correctly extend your MOSS site with ASP.NET AJAX.
    Here are the instructions.
    1. Extending your MOSS site with Microsoft ASP.NET AJAX 1.0 - http://www.telerik.com/help/aspnet-ajax/moss-install-aspnet-ajax.html
    2. Extending your MOSS site with Microsoft ASP.NET AJAX 3.5 - http://www.telerik.com/help/aspnet-ajax/moss-install-aspnet-ajax-35.html

    All the best,
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top
DevCraft R3 2016 release webinar banner