Rad DatePicker Value not getting in Code behind

4 posts, 0 answers
  1. Jesmon
    Jesmon avatar
    17 posts
    Member since:
    Jul 2012

    Posted 17 Aug 2012 Link to this post

    Hi,
        I have a Rad DateTimePicker in my Application and when i add one item to database  along with Rad DateTimePicker value showing error like this

     System.InvalidOperationException: Nullable object must have a value.   at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)   at System.Nullable`1.get_Value()  

    Actually  Rad DateTimePicker control has Value
    Please help me to solve this issue
    Thanks in Advance
    Jesmon Joseph

  2. Martin
    Admin
    Martin avatar
    811 posts

    Posted 22 Aug 2012 Link to this post

    Hello Jesmon,

    Could you please provide more details about your scenario. It would be very helpful if you could send some sample code or isolate the problem in a sample runnable page. This way I will be able to inspect and debug the code locally and provide more to the point resolution.

    All the best,
    Martin
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Owen
    Owen avatar
    4 posts
    Member since:
    Feb 2011

    Posted 06 Dec 2012 Link to this post

    Did you ever resolve this issue?  I do not have this issue until a user enters data using Safari on a Mac.  Once the user enters data, they can't get back to the page as we get this error message.  We use the .HasValue and we have stepped through the code.  In a windows environment we do not have the issue.  I can only assume that this is an issue with the RadDatePicker.  Your response would be greatly appreciated.

    Owen
  5. Martin
    Admin
    Martin avatar
    811 posts

    Posted 07 Dec 2012 Link to this post

    Hello Owen,

    As already stated, we are not able to replicate this issue in our side. Based in that I would suggest that you open a formal support ticket and send us a runnable example that demonstrates the problem. This way way we will be able to debug it locally and provide more to the point resolution.

    All the best,
    Martin
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top