R1 to R3 2012 Update Breaks TeamPulse

5 posts, 0 answers
  1. Marina
    Marina avatar
    10 posts
    Member since:
    Aug 2011

    Posted 13 Jun 2012 Link to this post


    Hello Telerik,

    I just updated TeamPulse from R1 2012 to R3 2012  and now the site will not open.  IIS is giving me an error on a missing configuration section for the page.  Need a solution urgently, please.

    Edmund

    Error Summary

    HTTP Error 500.19 - Internal Server Error

    The requested page cannot be accessed because the related configuration data for the page is invalid.

    Detailed Error Information
    Module IIS Web Core
    Notification BeginRequest
    Handler Not yet determined
    Error Code 0x80070032
    Config Error The configuration section 'system.web.extensions' cannot be read because it is missing a section declaration
    Config File \\?\C:\Program Files (x86)\Telerik\TeamPulse\wwwroot\web.config
    Requested URL http://localhost:9898/
    Physical Path C:\Program Files (x86)\Telerik\TeamPulse\wwwroot
    Logon Method Not yet determined
    Logon User Not yet determined
    Config Source
      113:   <system.codedom></system.codedom>
      114:   <system.web.extensions>
      115:     <scripting>
    
    Links and More InformationThis error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.
  2. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 14 Jun 2012 Link to this post

    Hi Edmund,

    I'm sorry to hear that upgrading cause you such problems.

    The problem is that for some reason the config section can't be found in .net framework configuration files.

    There are few things that can cause the problem.
    1. The AppPool under which the site is running is not .NET 4. In that case change the Framework version of the Application Pool to v4.0.
    2. You have nested application with .NET 2. (Only if you make changes with the default configuration of TeamPulse in IIS)

    If the above not fix it you can try to add on the top of the web.config:

    <configSections>
        <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
            <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
              <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere"/>
              <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
              <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
              <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
            </sectionGroup>
          </sectionGroup>
        </sectionGroup>

    I found some information for your problem here. Please go and check it if the things are not fixed.
    Let me know if you need some more help.Regards,
    Jordan
    the Telerik team
  3. Joel
    Admin
    Joel avatar
    300 posts

    Posted 14 Jun 2012 Link to this post

    This issue was handled in a support ticket so for the benefit of the larger community we will re-post the answer here.

    The issue was caused by the <system.web.extensions> section in the TeamPulse web site's web.config file.  To work around the issue, this section can be commented out like this:
     
    <!--<system.web.extensions>
      <scripting>
        <webServices>
          <authenticationService enabled="true" requireSSL="false" />
        </webServices>
      </scripting>
    </system.web.extensions>-->

    The reason this section exists is to enable integration scenarios.  The authentication service allows you to get an authentication cookie from our app without relying on your web browser.  The cookie is required when making requests to our data service or any other service that cannot be accessed anonymously.  If you don't need to integrate with TeamPulse in this way, it should be safe to leave this section commented out.


    After this issue was resolved another unrelated error occurred that was caused by a section of the web.config being locked by the global IIS configuration.  The error was the following:

    "This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false"."
    Config Source
      149:   <system.webServer>
      150:     <httpErrors errorMode="Detailed"/>
      151:     <modules runAllManagedModulesForAllRequests="true">


    This error was resolved by unlocking the httpErrors section in the global IIS configuration as illustrated in this blog post.


    Regards,
    Joel
    the Telerik team
  4. David
    David avatar
    1 posts
    Member since:
    Nov 2012

    Posted 22 Nov 2012 Link to this post

    I have the httperror problem and i did the steps in blog post. It didnt resolved the issue. I get the exact same error
     <httpErrors errorMode="Detailed"/>
  5. Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 27 Nov 2012 Link to this post

    Hi David,

     Can you send your whole error? Can you check if you can set the details errors in IIS?

    All the best,
    Jordan
    the Telerik team
Back to Top