"-" sign not working

4 posts, 1 answers
  1. joshua odell
    joshua odell avatar
    30 posts
    Member since:
    Sep 2008

    Posted 13 Jan 2010 Link to this post

    Hello.

    I've set the minimum value of my RadNumericUpDown to double.MinValue.  I am able to hit the "-" sign on the numeric keypad, but not on the keyboard itself (between the 0 and = buttons above the P key).  the RadNumericUpdown is filtering out this key.  This is apperant when using a laptop, as they don't have a numeric keypad, so the user has to hit the fn key in order to get the "-" sign.

    I had a similar issue with the "." key not working, I'm assuming this is more of the same.  Here is a link to that thread


    I really need an answer asap, and appreciate your help.

    Thanks
    Joshua

  2. Hristo Borisov
    Admin
    Hristo Borisov avatar
    298 posts

    Posted 14 Jan 2010 Link to this post

    Hi joshua odell,

    Thanks to your feedback we have decided to reimplement the way NumericUpDown handles input. There are just too many cases to filter specific key codes as the virtual key table sometimes varies in different laptop manufacturers. From SP2 on, that should be available later today, you will not have to worry about laptop vs desktop input or any of the sort, since the filtering is done after the textbox is updated. Of course this is done internally, and you will not notice any flickering of the textbox if typing correct or incorrect value. We have spend great amount of time testing all cases, but if you once again happen to experience the same issue please get back to us immediately, and your case will be resolved on the spot.

    Thank you for contacting us, and providing us with such a great feedback!

    Regards,
    Hristo Borisov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for WPF is Visual Studio 2017 Ready
  4. joshua odell
    joshua odell avatar
    30 posts
    Member since:
    Sep 2008

    Posted 14 Jan 2010 Link to this post

    Does that mean that there will be an internal build later today with that fix?
  5. Answer
    Hristo Borisov
    Admin
    Hristo Borisov avatar
    298 posts

    Posted 15 Jan 2010 Link to this post

    Hello joshua odell,

    Yes you are correct, but It is not an internal build, it is our official Q3 SP2 release. You can login in your Telerik Account and download the latest builds which should resolve your issue. If you still experience problems, please get back to us.

    Regards,
    Hristo Borisov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top