"d is undefined" when using AdvancedInsertTemplate

2 posts, 0 answers
  1. Datamex
    Datamex avatar
    161 posts
    Member since:
    Jun 2012

    Posted 30 Jul 2009 Link to this post

    When I use the AdvancedInsertTemplate, I get a javascript error "d is undefined" when I try to open my Advanced Insert form.

    <asp:ScriptManagerProxy runat="server" ID="AppointmentWebServiceScriptManager"
        <Services> 
          <asp:ServiceReference Path="~/WebServices/SchedulerWebService.asmx" /> 
        </Services> 
      </asp:ScriptManagerProxy> 
     
      <telerik:RadScheduler runat="server" ID="RadScheduler1" SelectedView="WeekView" StartEditingInAdvancedForm="true" DataKeyField="AppointmentID" 
        CustomAttributeNames="Customer" EnableCustomAttributeEditing="true"  StartInsertingInAdvancedForm="true"
          <AdvancedForm Modal="true" /> 
          <TimelineView GroupBy="Employee" GroupingDirection="Vertical" SlotDuration="1:00:00" NumberOfSlots="20" /> 
          <WebServiceSettings Path="~/WebServices/SchedulerWebService.asmx" ResourcePopulationMode="ServerSide" />       
           
          <AdvancedEditTemplate> 
            <div><asp:Label ID="TestEdit" runat="server" Text="TEST"></asp:Label></div> 
          </AdvancedEditTemplate>   
           
          <AdvancedInsertTemplate> 
            <div><asp:Label ID="TestInsert" runat="server" Text="TEST"></asp:Label></div> 
          </AdvancedInsertTemplate>              
      </telerik:RadScheduler> 

    The full error:

    Fout: d is undefined
    Bronbestand: http://localhost:2780/Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=ctl00_ScriptManagerControl_HiddenField&compress=1&_TSM_CombinedScripts_=%3b%3bSystem.Web.Extensions%2c+Version%3d3.5.0.0%2c+Culture%3dneutral%2c+PublicKeyToken%3d31bf3856ad364e35%3anl%3a0d787d5c-3903-4814-ad72-296cea810318%3aea597d4b%3ab25378d2%3bTelerik.Web.UI%2c+Version%3d2009.2.701.35%2c+Culture%3dneutral%2c+PublicKeyToken%3d121fae78165ba3d4%3anl%3a7e598a31-3beb-49a1-914c-5f530240f0ea%3a16e4e7cd%3aed16cbdc%3a86526ba7%3a874f8ea2%3af7645509%3a24ee1bba%3a19620875%3a39040b5c%3af85f9819%3ae330518b%3a1e771326%3ac8618e41%3a650fdad%3ad40f7d5c%3a1a9ac27f%3a7d98db04%3afe65db44%3a63767fed%3a44e9d927%3a26c790aa%3a3cdff5d5%3ae91ff703%3a7666c7ed%3aef9d9f4a%3aa960fda2%3aca44ff11%3aa51ee93e%3a59462f1
    Regel: 7374

    I'm using Telerik for ASP.NET AJAX RadControls 2009 Q2. Can somebody tell me what I am doing wrong?
  2. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 30 Jul 2009 Link to this post

    Hi,

    Can you isolate the problem in a simple working project and send it to us for testing via a support ticket?


    Greetings,
    Peter
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top