QuickAccessToolbar: separator not working in Office2013 theme

7 posts, 1 answers
  1. Patrick
    Patrick avatar
    372 posts
    Member since:
    Aug 2012

    Posted 13 Feb 2014 Link to this post

    Hello,
    I would like to add a separator between two button groups in the Quick Access Toolbar. After adding the separator in the XAML, the separator is not displayed.
    Is this a bug in the Office2013 theme?
    Patrick
  2. Boris
    Admin
    Boris avatar
    276 posts

    Posted 17 Feb 2014 Link to this post

    Hello Patrick,

    When separating items in the Quick Access Toolbar it's best to use our RadToolBarSeparator

    <telerik:RadToolBarSeparator Background="Red" />
    Actually the QuickAccessToobar class inherits RadToolBar which supports only a set of controls and has predefined styles for them:
    • RadToolBarSeparator
    • Button and RadButton
    • ToggleButon and RadToggleButton
    • RadioButton and RadRadioButton
    • RadDropDownButton
    • RadSplitButton
    • CheckBox
    • TextBlock
    • TextBox

    This is why you cannot see the Separator when you place it in the Quick Access ToolBar.
    On a side note, the way to set custom styles on the items placed in the RadToolBar is demonstrated in this SDK sample

    Please let us know if this helps you.

    Regards,
    Boris Penev
    Telerik

    Check out the new Telerik Platform - the only modular platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native apps. Register for the free online keynote and webinar to learn more about the Platform on Wednesday, February 12, 2014 at 11:00 a.m. ET (8:00 a.m. PT).

  3. UI for WPF is Visual Studio 2017 Ready
  4. Patrick
    Patrick avatar
    372 posts
    Member since:
    Aug 2012

    Posted 17 Feb 2014 in reply to Boris Link to this post

    Hi Boris,
    thanks for the answer: I will try it in a moment, but you should really correct the documentation, as it said for Quick Access Toolbar:

    When you want to add toolbar items to your RadRibbonView's Quick Access
    Toolbar, you need to populate the QuickAccessToolbar's Items
    collection. It is handy to use the RadRibbonButton,
    RadRibbonSplitButton, RadRibbonDropDownButton and Separator
    controls.

    Patrick
  5. Patrick
    Patrick avatar
    372 posts
    Member since:
    Aug 2012

    Posted 17 Feb 2014 in reply to Patrick Link to this post

    Hi Boris,
    it works with RadToolBarSeparator, but the size of the separator is not correct, as you can see on this screen shot, using the Office2013 theme.
  6. Patrick
    Patrick avatar
    372 posts
    Member since:
    Aug 2012

    Posted 17 Feb 2014 in reply to Patrick Link to this post

    Hi Boris,
    it works with RadToolBarSeparator, but the size of the separator is not correct, as you can see in the attached screen shot, using the Office2013 theme.
    Patrick
  7. Answer
    Boris
    Admin
    Boris avatar
    276 posts

    Posted 19 Feb 2014 Link to this post

    Hello Patrick,

    I have prepared a sample project that demonstrates how you can use Office2013 implicit styles (using NoXaml binaries) and edit the size of the RadToolBarSeparator. In order to do that I set MinHeight and Height of the RadToolBarSeparator via Style like so:

    <Window.Resources>
            <Style TargetType="telerik:RadToolBarSeparator" BasedOn="{StaticResource RadToolBarSeparatorStyle}">
                <Setter Property="MinHeight" Value="10" />
                <Setter Property="Height" Value="20" />
            </Style>
        </Window.Resources>
    This is needed because the MinHeight is set to 24 by default in Office2013 theme.
     
    As for the misleading documentation article, I agreee with you, I logged it in our system internally and this will be fixed in future releases. I also updated your telerik account points as a thanks for your cooperation.

    Regards,
    Boris Penev
    Telerik
  8. Patrick
    Patrick avatar
    372 posts
    Member since:
    Aug 2012

    Posted 19 Feb 2014 in reply to Boris Link to this post

    Hello Boris,
    thank you for the tip, but just setting the MinHeight property to 18 does the trick.
    Note that the right value is 18, not 20.
    Patrick
Back to Top
UI for WPF is Visual Studio 2017 Ready