question about datasource

3 posts, 1 answers
  1. Robert Strazzarino
    Robert Strazzarino avatar
    41 posts
    Member since:
    Jan 2006

    Posted 23 Jun 2010 Link to this post

    I have a report that has only a table in the detail section.  I found that if have a datasource added to the report and  also the same datasource assigned to the table then the report data has the data repeated -  First black of data then the same block repeated.  If I remove the datasource for the report then the data is only shown once.
    Why is this happening?
    Thanks,
    Robert
  2. Robert Strazzarino
    Robert Strazzarino avatar
    41 posts
    Member since:
    Jan 2006

    Posted 26 Jun 2010 Link to this post

    This shows as having a reply but there is only one entry.  I really would like to know what the issue is.

    Thanks,
    Robert
  3. DevCraft banner
  4. Answer
    Peter
    Admin
    Peter avatar
    1611 posts

    Posted 28 Jun 2010 Link to this post

    Hello Robert Strazzarino,

    This is the expected behavior. If you set the Report's DataSource property, the detail section displays at run-time one row for each detail item in the report data source. On the other side the Table report item is a separate data region and does not make use of the report's data source, but if placed in the detail section, would be repeated like any other item.

    Greetings,
    Peter
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top