Q3 2009 IE8 in compatibility mode: additional "line" is displayed under the text area.

21 posts, 0 answers
  1. Sylvain
    Sylvain avatar
    31 posts
    Member since:
    Jun 2006

    Posted 05 Nov 2009 Link to this post

    Just go the the radcombobox demos with IE8, switch to compatibility view and you will see a line under the text area(most skins) and the drop down arrow (some skins). Seems not to happen at all for some skins. Use Vista skin and you'll see it.

    Doesn't happen on IE6, IE7 or FF.

  2. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 06 Nov 2009 Link to this post

    Hello Sylvain,

    We couldn't reproduce the additional line you were talking about here. Can you post a screenshot of what you are seeing?

    Kind regards,
    Kamen Bundev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Sylvain
    Sylvain avatar
    31 posts
    Member since:
    Jun 2006

    Posted 06 Nov 2009 Link to this post

    Please see the screenshot from the telerik demos in IE8 compatibility view and the Vista skin.
  5. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 06 Nov 2009 Link to this post

    Hi Sylvain,

    Can you check if you have a small zoom factor enabled in IE8? IE8's zoom is slightly broken for table cell backgrounds and they tend to get differently scaled (also the zoom factor persists between sessions). Check the bottom right corner of your browser if this is the case.

    Best wishes,
    Kamen Bundev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Sylvain
    Sylvain avatar
    31 posts
    Member since:
    Jun 2006

    Posted 06 Nov 2009 Link to this post

    The zoom is set at 100% (compatibility view).
    As a side note, I did notice that in IE8 (not in compatibility view), if I set the zoom to 125% or 75%, I do see the same kind of lines appear on some of the comboboxes, and not at 100%.
    The only other thing I can add is that the IE8 I'm running is through virtual PC, but I'm not sure if that would make a difference.
  7. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 12 Nov 2009 Link to this post

    Hello Sylvain,

    Do you have a forced font-family in your internet options (Ignore font style option in Accessibility tab)? In IE7 the font height and line height are related for block elements.

    Regards,
    Kamen Bundev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  8. Sylvain
    Sylvain avatar
    31 posts
    Member since:
    Jun 2006

    Posted 12 Nov 2009 Link to this post

    No I don't have anything checked in the Accessibility options. I will also try it on a different machine and see what happens. Am I really the only one to see that extra line?
  9. Paul
    Admin
    Paul avatar
    4281 posts

    Posted 16 Nov 2009 Link to this post

    Hello Sylvain,

    Yes, indeed. In most of the cases, such visual glitches are caused by the zooming feature of the browser. Still, we are not able to reproduce this particular case by changing the zoom level. Let us know if you find any additional details that might help.

    Best wishes,
    Paul
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  10. Mario
    Mario avatar
    75 posts
    Member since:
    Jun 2009

    Posted 20 Nov 2009 Link to this post

    hi,

    have same line under my comboboxes since i switched from an older version of telerik to the current version. I use skin outlook.

    i just installed IE8. didnt configure anything or set zoom.

    i also work in a virtual machine workstation with win xp.

    no under line in firefox, only IE8.

    @zooming: yes the line change its appearance at different zoom levels..

    greets mario.




  11. Simon
    Admin
    Simon avatar
    2281 posts

    Posted 20 Nov 2009 Link to this post

    Hi Mario,

    Please include the following CSS on the erroneous page to resolve the issue:

    *+html div.RadComboBox_ComboBox .rcbArrowCell a
    {
        line-height: 16px;
        height: 22px;
    }
     
    * html div.RadComboBox_ComboBox .rcbArrowCell a
    {
        line-height: 16px;
        height: 22px;
    }

    All the best,
    Simon
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  12. Sylvain
    Sylvain avatar
    31 posts
    Member since:
    Jun 2006

    Posted 20 Nov 2009 Link to this post

    Simon,

    It still shows the line in IE8 in compatibility view. It looks good ie IE6, IE7, IE8 (IE8 rendering) and FF3.5.
    Any ideas?

    Sylvain
  13. Simon
    Admin
    Simon avatar
    2281 posts

    Posted 20 Nov 2009 Link to this post

    Hello Sylvain,

    I was unable to reproduce this issue in the live demo you have referred to previously in all IE8 Compatibility View modes.

    Have you changed the fonts of the page?

    All the best,
    Simon
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  14. Sylvain
    Sylvain avatar
    31 posts
    Member since:
    Jun 2006

    Posted 20 Nov 2009 Link to this post

    No I haven't changed anything in the browser config as far as fonts are concerned. Moreover, I just received a new PC which exhibits the same problem as the other PC. They both have Windows XP SP3, IE8 and all the latest service packs from MS installed. I see the problem on my sites and yours on both machines.
  15. Simon
    Admin
    Simon avatar
    2281 posts

    Posted 20 Nov 2009 Link to this post

    Hello Sylvain,

    Then could you please let me know the exact version of your IE8 browser?

    Regards,
    Simon
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  16. Sylvain
    Sylvain avatar
    31 posts
    Member since:
    Jun 2006

    Posted 20 Nov 2009 Link to this post

    The version is: 8.0.6001.18702CO
  17. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 23 Nov 2009 Link to this post

    Hello Sylvain,

    Thank you, we managed to reproduce it and the issue should be fixed in the next internal build and service pack (and partially the problems when changing fonts). I've updated your Telerik points for the help.

    Regards,
    Kamen Bundev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  18. Mihir Pathak
    Mihir Pathak avatar
    14 posts
    Member since:
    Aug 2009

    Posted 08 Mar 2010 Link to this post

    I am trying to used 2009_3_1407 hot fixed, but its the same issue. is there any latest hot fix available?
  19. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 09 Mar 2010 Link to this post

    Hello Mihir,

    We are unable to reproduce the issue with the build you mention. Are you sure its the same issue? Can you tell us a bit more about your problem and maybe send us a screenshot or a live URL? Thank you in advance.

    Sincerely yours,
    Kamen Bundev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  20. Mihir Pathak
    Mihir Pathak avatar
    14 posts
    Member since:
    Aug 2009

    Posted 09 Mar 2010 Link to this post

    Hi,

    Here are couple of screen shot in IE and Sarafi browser. IE is the one where its not compatible. In Telerik website Combobox render  fine. I see the problem with my Website only. I do remember that we have IIS setting to run the pages only in IE7 compatibility view.
    I am using  2009.3.1407.20 version of telerik.Web.UI.dll. 

    Thanks
    MP 
  21. Kamen Bundev
    Admin
    Kamen Bundev avatar
    1532 posts

    Posted 09 Mar 2010 Link to this post

    Hello Mihir,

    I'm still not able to reproduce the issue you have with 2009.3.1407.20. Could be a global CSS style from another of your stylesheets that interferes with the RadComboBox rendering. Can you file a support ticket with a live URL to your project so that we can take a look? Thank you in advance.

    Best wishes,
    Kamen Bundev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  22. Mihir Pathak
    Mihir Pathak avatar
    14 posts
    Member since:
    Aug 2009

    Posted 09 Mar 2010 Link to this post

    Hi Kamen,
    Thanks for the reply and pointing out the css issue.
    Here is the Anchor style that is causing the issue. After taking bold part out it fixed the problem. I am not sure why Anchor style is written like that :).

    A { COLOR: #003399; TEXT-DECORATION: none;font-family: Arial, Helvetica, sans-serif; }

    Thanks for the help.
    MP

Back to Top
UI for ASP.NET Ajax is Ready for VS 2017