Proxy Registry Settings Untouchable

12 posts, 0 answers
  1. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 18 Nov 2014 Link to this post

    Yes I have tried resetting IE settings
    Yes I have disabled and re-enabled IE
    Yes I have tried the following steps:
    1: Use Help > Troubleshoot Filters to make sure the traffic isn't getting hidden unexpectedly. --Nothing hidden
    2: Look in the Log tab to see if there's a note about Chrome Group Policy hardcoding the proxy. --Recently set Chrome Policy to try and fix the issue. Not problematic
    3: Update your question to mention whether other browsers' traffic is captured. --Nothing is captured except for Echo Service
    4: Visit http://localhost.fiddler:8888/ in Chrome; What if anything do you see? --Echo Service
    5: Visit http://127.0.0.1:8888/ in Chrome; What if anything do you see? --Echo Service
    I have also tried to manually modify the registry settings. The result was Fiddler overriding them. I have tried process monitor, nothing is being captured at all.
    After setting the Chrome Policy, it works, for Chrome anyways. I have disabled EVERY Chrome expansion. Nothing. I have also deleted Registry Keys, nothing.
    I have crashed Windows trying to fix this, believe me I went in-depth. I have uninstalled the following as well to try:
    1: Evolve VPN
    2: Teamviewer VPN
    3: Wireshark
    4: WinPCap
    5: Fiddler (Reinstalled)
    6: CommView
    With the exception of Fiddler, I have reinstalled nothing above. I do have Hamachi VPN installed, but I know it works for that. Note I am having the same exact issue on another laptop, meaning it is not entirely unique. The registry override ONLY occurs when refreshing Fiddler after registry change. I am ready to post any files I need.

  2. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 18 Nov 2014 in reply to Tyler Link to this post

    I forgot to include:
    I have used Fiddler before, and I loved it. I need more like it. But with the Chrome Policy I should be able to do what I need to do, for now. Yes, I am a programmer, I am using Fiddler to make it easier for my to determine how to do what I need to do, instead of hours of research.
  3. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 19 Nov 2014 Link to this post

    Hi, Tyler-- Thanks for all of the details, but it's not really clear to me what problem you're having. Are you having a problem capturing traffic from IE?

    This: 4: Visit http://localhost.fiddler:8888/ in Chrome; What if anything do you see? --Echo Service

    Means that your browser is sending traffic correctly to the proxy (otherwise, localhost.fiddler would be shown as a DNS error in your browser).

    If your problem isn't with Chrome, follow the steps in the browser you're having trouble with.

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  4. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 19 Nov 2014 in reply to Eric Lawrence Link to this post

    #4 is now a DNS error, I might have had group policy enabled at the time. #5 has always been Echo Service.
    When I edit the registry files, it seems like Fiddler is preventing it from enabling. Fiddler thinks it is running and does receive things sent to 8888 but does not actually cause anything to be routed that direction. Basically I listens but doesn't proxy I suppose. And because of this it only works for chrome. And no IE is not picked up.
  5. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 19 Nov 2014 in reply to Eric Lawrence Link to this post

    Error 500 so this will be short and snappy, sorry I don't want to re-write it
    #4 Is now a DNS issue Liekly had policy active for chrome at time
    IE does not get picked up
    It does listen on port 8888
    Doesn't proxy so I cannot use it outside chrome.
  6. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 19 Nov 2014 in reply to Eric Lawrence Link to this post

    Error 500 so this will be short and snappy, sorry I don't want to re-write it
    #4 Is now a DNS issue Likely had policy active for chrome at time
    IE does not get picked up
    It does listen on port 8888
    Doesn't proxy so I cannot use it outside chrome.
  7. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 20 Nov 2014 Link to this post

    Just to be clear here, Fiddler doesn't "send traffic" to itself; it's up to the client to send traffic to Fiddler. Typically, this works automatically, because the client picks up the system proxy settings (which Fiddler sets) and respects them.

    If Fiddler is unable to set the system proxy (e.g. because there's security software that prevents it, or other software that immediately overwrites its changes) then traffic will not be sent to Fiddler, but the "Echo" page will remain available at http://127.0.0.1. You can see what proxy is currently configured by choosing Tools > WinINET Options > LAN Settings inside Fiddler or Tools > Internet Options > Connections > LAN Settings inside IE.

    Another case occurs when the system's proxy setting logic is broken and the settings cannot be changed. To check for that, without Fiddler running, go to the LAN Settings and configure a bogus proxy (e.g. http://bazinga on port 9999). Click OK on the dialogs and then reopen them. If the settings weren't preserved, then the system APIs are broken. This could be a result of a bug in the OS, or VPN software, or malware, or any host of other similar issues.

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  8. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 20 Nov 2014 in reply to Eric Lawrence Link to this post

    I believe I have attempted it before without my antivirus, so it couldn't be that. Bogus port settings don't work. I don't remember installing any security software since it has ceased.
  9. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 26 Nov 2014 Link to this post

    If the logic is broken, can you provide information on a fix (if possible)
  10. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 26 Nov 2014 Link to this post

    Hello, Tyler--

    A Process Monitor log, filtered to the ProxyServer registry key would be useful to see what exactly is happening. Bugs in the proxy settings API have been reported to the WinINET team at Microsoft, but as no one has a reliable repro, I don't think they've made any progress in finding the root cause. You might try using IE's Tools > Internet Options > Advanced > Reset... but there's no particular reason to believe that this will work.

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  11. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 26 Nov 2014 in reply to Eric Lawrence Link to this post

    Resetting options don't work as expected
    And from what I can tell ProcessMonitor is picking not a thing up, and strangly not even Fiddler, although I, as said before, believe it may be causing it. Regardless, nothing is determined. Internet Options don't work of course but when modifiying the registry settings for manual changing, Fiddler appears to override it, regardless of ProcessMonitor's lack of ability to detect crap.
  12. Tyler
    Tyler avatar
    9 posts
    Member since:
    Nov 2014

    Posted 01 Jan 2015 Link to this post

    I have re-installed windows in the attempt to go from 32-bit to 64-bit. In the process this issue has been resolved if that means anything.
Back to Top