Property Grid refresh issue when item changes

8 posts, 0 answers
  1. Dave
    Dave avatar
    29 posts
    Member since:
    Aug 2010

    Posted 22 Mar 2013 Link to this post

    We are using the Property Grid's AutoGeneratingPropertyDefinition event and accessing the AutoGeneratingPropertyDefinitionEventArgs object to set the GroupName and EditorTemplate of each of our properties.

    We updated to the newest dlls and are now noticing that when we change the Item the grid is bound to, the property grid does not refresh with the new values of selected item. Toggling between Categorical and Alphabetical view modes does refresh the bindings in the grid though.

    I can upload an example project if you need.


    Thanks,
  2. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 25 Mar 2013 Link to this post

    Hello,

    We are already aware of such an issue and it should be resolved with the latest internal build scheduled to be released later today. Please test with it and let me know about the result.
     

    All the best,
    Didie
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. DevCraft banner
  4. Nathaniel
    Nathaniel avatar
    68 posts
    Member since:
    Nov 2010

    Posted 02 May 2013 Link to this post

    Did the fix for this issue make the 4_03 build?  I using 4_03 build and I'm seeing this issue.

  5. Maya
    Admin
    Maya avatar
    4062 posts

    Posted 03 May 2013 Link to this post

    Hi Dave,

    Could you try downloading our latest internal build from your telerik account and give it a try ?  Do you still get the same behavior ? 

    Kind regards,
    Maya
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  6. Dave
    Dave avatar
    29 posts
    Member since:
    Aug 2010

    Posted 03 May 2013 Link to this post

    Seems to be fixed now. Is it scheduled to be in the next quarterly release?
  7. Maya
    Admin
    Maya avatar
    4062 posts

    Posted 03 May 2013 Link to this post

    Hello Dave,

    I am glad too see that the issue is resolved in your scenario as well. Considering the fix, it will be part of our official release - Q2 2013 coming in June. 

    All the best,
    Maya
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  8. Nathaniel
    Nathaniel avatar
    68 posts
    Member since:
    Nov 2010

    Posted 08 May 2013 Link to this post

    I Just installed the 5_07 internal build and the problem still exists.

  9. Maya
    Admin
    Maya avatar
    4062 posts

    Posted 08 May 2013 Link to this post

    Hi Nathaniel,

    Will it be possible to clarify a bit what your exact scenario is ? How is the property grid bound ? What is the object it is bound to, how you change the item ?
    Generally, any relevant information on your case would be helpful. 

    Regards,
    Maya
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top
DevCraft banner