Properties assigned letter s

2 posts, 0 answers
  1. Richard
    Richard avatar
    2 posts
    Member since:
    Nov 2012

    Posted 08 Jul 2013 Link to this post

    How to have not append letter 's' in the properties

     CREATE TABLE [dbo].[m00PersonaIdentidad](
    [IdPersonaIdentidad] [int] IDENTITY(1,1) NOT NULL,
    [IdPersona] [int] NOT NULL,
    [TipoDocumento] [tinyint] NOT NULL,
    [Nombre] [varchar](20) NOT NULL

    public IQueryable<M00PersonaIdentidad> M00PersonaIdentidads 
    return this.GetAll<M00PersonaIdentidad>();

    should modify a template?
  2. Alexander
    Alexander avatar
    727 posts

    Posted 08 Jul 2013 Link to this post

    Hi Richard,

    I am afraid that currently there is no way to disable the pluralization of context endpoints. Please vote for this functionality in our Ideas & Feedback portal.

    At the moment the only workaround is to rename the endpoint manually by selecting it in Model Object Explorer and changing its name in Properties pane.

    OpenAccess ORM Q2 2013 brings you a more powerful code generation and a unique Bulk Operations support with LINQ syntax. Check out the list of new functionality and improvementsshipped with this release.

  3. DevCraft banner
Back to Top