Project Upgrade Additional Issue

4 posts, 0 answers
  1. Lynn
    Lynn avatar
    186 posts
    Member since:
    Sep 2006

    Posted 17 Feb 2012 Link to this post

    I just downloaded and installed the latest release.  I upgraded two different web sites to the new controls (when your code asked if I wanted to upgrade).

    I now have two projects that were previously using the Sitefinity skin and now everything is blowing up when it tries to display using that skin.  I haven't tried any other skins because I'm hopping mad that my producitivity has just been shot in the foot.

    Do you have a way of fixing these large projects or can you send someone over to rebuild them for me?

    I have attached a screen capture of the yellow screen of .net death for your enjoyment.

    Lynn

  2. Chavdar Dimitrov
    Admin
    Chavdar Dimitrov avatar
    104 posts

    Posted 20 Feb 2012 Link to this post

    Hello Lynn,

    Sorry for experiencing troubles after upgrading to the latest version.

    It's possible to get this error if your project doesn't reference the Telerik.Web.UI.Skins assembly. This is because with Q3 2011 all skins (except the 'Default' one) were moved to this assembly. You can read more about the skins transition here.

    If the Telerik.Web.UI.Skins reference is missing, the easiest way to add it is using the Configuration Wizard.

    I hope this will help. Let me know if you need any further assistance.

    Kind regards,
    Chavdar,
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Lynn
    Lynn avatar
    186 posts
    Member since:
    Sep 2006

    Posted 30 Mar 2012 Link to this post

    To be honest, I am well aware that the skins were moved to the .dll. 

    I can create a NEW Telerik web site project and everything in the project is set up correctly and runs fine.

    But, when I open a project and the Telerik "little green dialog box" comes up in Visual Studio telling me there is an upgrade available on my machine and I tell it to go ahead and update the project, then afterwards the project is totally screwed up, the web.config is ruined and the project will not run.  It errors out with a .net "yellow screen of death" telling me it cannot find a Telerik skin named "(pick any Telerik skin the project was already defined for)".  After this happens, I have to create another new project.

    This ALWAYS happens if I allow your project upgrade process to run.  I've just had it happen two more times today.  This is really a problem with your upgrade process.  It is not that I do understand where the skins are stored.

    Why?

    Lynn

  5. Chavdar Dimitrov
    Admin
    Chavdar Dimitrov avatar
    104 posts

    Posted 02 Apr 2012 Link to this post

    Hello Lynn,

    It seems that the problem concerns the changes that are made in the web.config during the upgrade process.

    Is it possible to send us the project (or an example one) that reproduces the problem, so that we can examine it? This will be very helpful and we will do our best to fix the issue for one of our upcoming releases.

    Additionally, could you describe the exact steps that you went through to get this error? What was your old version? What is the version you upgraded to?

    Looking forward to your reply.

    Kind regards,
    Chavdar,
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top