Problems with the child items

3 posts, 0 answers
  1. David Cardona
    David Cardona avatar
    20 posts
    Member since:
    Mar 2010

    Posted 16 Apr 2010 Link to this post

    Hello.

    I have some problems when I add childs to the element at the second level. I can´t expand the element, only appears a button!!!

    Please see the imagen at the atach file or click in next link

    http://img96.imageshack.us/img96/1961/treeviewproblem.png

    Thank you so much
  2. Miroslav
    Admin
    Miroslav avatar
    922 posts

    Posted 19 Apr 2010 Link to this post

    Hi David Cardona,

    This is indeed unexpected.

    Can you give us more information about this -
    - How do you add the children?
    - Are you updating the collection that the ItemsSource of the elements is databound to?
    - The items appear visually different. Are you using a custom ControlTemplate or an (ItemContainer)Style?

    All the best,
    Miroslav
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DevCraft banner
  4. David Cardona
    David Cardona avatar
    20 posts
    Member since:
    Mar 2010

    Posted 19 Apr 2010 Link to this post

    Hi Miroslav , thank you for your answer.

    I resolved the situation, I was creating the items like TreeViewItems , the error was resolved creating the items like TreeListViewItems.

    It is all.


    Thank you so much
Back to Top