Problems with Rad Spell_ disable AllowAddCustom

4 posts, 0 answers
  1. ishan
    ishan avatar
    3 posts
    Member since:
    Oct 2008

    Posted 06 Oct 2008 Link to this post

    Hi,

     I am using Version 7.0.0.0 of RadEditor, Version 3.0.0.0 of the RadSpell. and .Net framework 1.1

    I set the value in RadControls\Editor\Config.xml to be false for AllowAddCustom but it doesn't work.

    <property name="AllowAddCustom">false</property>

    In the config file, there are some “property element valid attributes” given but there is no property called “AllowAddCustom”.

    I added “AllowAddCustom” to this section but still it did not work.


    On page load, I cannot code these properties to change or set any values because the spell checker is used in several places and making the changes in the page load in every page will involve lot of coding effort.

     How do I resolve this problem?

     

    Note:

    When I make changes to the RadControls\Editor\toolsFile.xml (such as disable the copy button) the changes are reflected in the UI.

  2. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 07 Oct 2008 Link to this post

    Hi Ishan,

    By default, RadEditor does not load and read its ConfigFile.xml and the properties in it are not applied. You should set the editor's ConfigFile property to point to the ConfigFile.xml file, e.g.

    <rade:RadEditor ConfigFile="~/RadControls/Editor/ConfigFile.xml" ID="RadEditor1" runat="server"></rade:RadEditor>

    Greetings,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. ishan
    ishan avatar
    3 posts
    Member since:
    Oct 2008

    Posted 07 Oct 2008 Link to this post

    Hi,

     Thanks for the quick reply.

     I added the ConfigFile value as follows. The changed code as follows,

     <ts:VisualEditor visible="true"

              id="AnnouncementEditor"

              runat="server"

              Height="150px"

              Width="100%"

              TextareaCols="97"

              TextareaRows="25"

              EditorClientScriptUrl="ClientScripts/"

              ForegroundColorWizardUrl="ClientScripts/selcolor.htm"

              TableWizardURL="ClientScripts/instable.htm"

              FullScreenEditorPageUrl="VisualEditorFullScreenAnouncement.aspx"

              ShowLinkWizardButton="False"

              SpellCheckerWizardURL="SpellCheck.aspx"

              ConfigFile="RadControls/Editor/ConfigFile.xml">

    </ts:VisualEditor>

     I set the value in RadControls\Editor\Config.xml to be false for AllowAddCustom 

     <property name="AllowAddCustom">false</property>

    But still the add custom words feature is not disabled. How can I disable this?

     Please assist as soon as possible

     Thank you,

    Ishan

    Note:

    The Config.xml file is in, RadControls\Editor\ folder.

  5. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 07 Oct 2008 Link to this post

    Hi Ishan,

    Could you please, open a support ticket from your Client.net account and send a sample fully working project that demonstrates the problem? I will examine it and provide a solution after that.

    Best regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Back to Top