Problem with x-axis label placement

Thread is closed for posting
3 posts, 0 answers
  1. Scott
    Scott avatar
    9 posts
    Member since:
    Jul 2012

    Posted 09 Jan 2013 Link to this post

    Hello forums,

    We are having a weird issue with RadChart in that sometimes the chart goes wonky when it is placing the labels for the dots on a line chart.  Yes, the dots are a bit close together, but it doesn't seem like they are all that terribly close together.  It's possible that this is just a RadChart bug.  We are currently using RadChart ( AJAX) version 2012.2.828.40.  Attached are some sample graphs for you to peruse.  Any suggestions of things we could try to tweak to keep this from happening would be welcome.

    Thanks in advance,

  2. MasterChiefMasterChef
    MasterChiefMasterChef avatar
    152 posts
    Member since:
    Jan 2013

    Posted 14 Jan 2013 Link to this post

  3. DevCraft R3 2016 release webinar banner
  4. Missing user
    Missing user avatar

    Posted 14 Jan 2013 Link to this post

    Hello Scott,

    The issue you're experiencing is caused by setting the IntelligentLabelsEnabled property of RadChart to true. This feature has been added to prevent item labels from overlapping each other when there are too many items in a series, just as you've guessed.

    Therefore, we can suggest 2 courses of action: you can either set IntelligentLabelsEnabled to false or you can give the RadChart more space to render itself. Please, consider these and see how they'll work out for you.

    Ivan N.
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top