Problem with Live Example Radcontrols for ASP.Net Ajax 2009 Q3 SP2

6 posts, 0 answers
  1. Arshavir
    Arshavir avatar
    3 posts
    Member since:
    Jul 2007

    Posted 23 Jan 2011 Link to this post

    Hi,

    I have Windows Vista Ultimate SP1 and VS 2008.
    I had successfully installed Telerik 2009 Q3, but when I run Live Example Rad Control, page shows "sys is undefined" JS error and all of controls shows like a lot of bullet.
    I tried all of related solutions in this forum but the problem is still exist.
    In the other hand I have the same problem when I use controls in VS2008.
    It seems very unusual :-)
    Any ideas?
  2. Erjan Gavalji
    Admin
    Erjan Gavalji avatar
    1455 posts

    Posted 24 Jan 2011 Link to this post

    Hi Arshavir,

    Can you check the control panel for ASP.NET AJAX Extensions 1.0? If existing, can you please, follow the steps below:

    • remove the ASP.NET AJAX Extensions 1.0;
    • download the official package;
    • install it

    Kind regards,
    Erjan Gavalji
    the Telerik team
    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Arshavir
    Arshavir avatar
    3 posts
    Member since:
    Jul 2007

    Posted 25 Jan 2011 Link to this post

    Dear Erjan,
    thanks for your reply.
    I remove and install official package again but the problem is still exist. is there any other solution?

    Best,
  5. Edward
    Edward avatar
    12 posts
    Member since:
    Oct 2009

    Posted 27 Jan 2011 Link to this post

    Hi,

    After some looking around the web, it seems the issue may be related to bugs in Internet Explorer 6. I discovered the following post in the official ASP.NET forums:
    'Sys' is undefined

    I know you mentioned you've gone through the Telerik forums, but just in case, here are my findings after doing the same:
    Common reasons for the ‘Sys is undefined’ error in ASP.NET Ajax applications
    Sys is undefined

    BR,
    Eddie
  6. Arshavir
    Arshavir avatar
    3 posts
    Member since:
    Jul 2007

    Posted 11 Feb 2011 Link to this post

    Dear Edward,

    Thanks for your suggestions, unfortunately I tried all of them before and it doesn't work.
    I installed VS2010 and RadControls 2010 Q3. page runs without any error but controls do not run complete. for example all images in radeditor toolbar are missing (please see attached file).
  7. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 16 Feb 2011 Link to this post

    Hi Arshavir,

    You could experience this problem after an application restart. The toolbar image sprite used by the different tools is loaded from the embedded resources in the Telerik.Web.UI.dll which and has a dynamic url. When the application is restarted, the web browser is trying to load the old invalid path to the embedded resource, but not the newly generated one.

    You can easily fix this browser caching problem, by registering the skin of RadEditor from a CDN server or the external skins of the control which have fixed paths.

    Best regards,
    Rumen
    the Telerik team
    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017