Problem with isreadony propoerty

2 posts, 0 answers
  1. Hardik
    Hardik avatar
    61 posts
    Member since:
    Jun 2011

    Posted 17 Oct 2011 Link to this post

    Hi telerik,

    In my project I want to disable few of the time where user is not working, So using specialSlotsouce i am able to make few of the slots disable(IsreadOnly = true).

    All this is working fine, but today I found one scenario where this is not working. In my project by default whole day is IsreadOnly. WhereEver user is available I make that slot enable(Isreadonly set to false).

    For specific timing this is not working.

    like I create two different slots 10:00 am to 1:00 pm and 1:00 pm to 3:00 pm. here IsreadOnly = false. All other timing IsReadOnly = true

    In this case at 1:00 pm I am not able to create the appointment. As I change the MinorTickLength and MajorTickLength to 1 min then I found that I can create the appointment to 1:01 pm , 1:02 pm, 1:03 pm even at 12:59 pm but not able to create appointment on 1:00 pm.

    If minorTickLength and majorTickLenght is set to 10 min then I am not able to create appointment for 1:00 to 1:10 slot. same for 15 min, 30 min etc....

    Don't you think this is a bug.
  2. Rosi
    Admin
    Rosi avatar
    2527 posts

    Posted 19 Oct 2011 Link to this post

    Hello Hardik,

    I think this cannot be consider as a bug in RadScheduleView. Setting the End property of a readonly slot to be 1.00p.m includes the 1.00 p.m. itself. To change this behavior I suggest you modify your readonly slot to end in 12:59 and not to include 1p.m.


    Kind regards,
    Rosi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
Back to Top