Problem with DefaultButton in Q1 2012

35 posts, 0 answers
  1. Marian
    Marian avatar
    49 posts
    Member since:
    Sep 2008

    Posted 21 Feb 2012 Link to this post

    Hi to all,
    I have upgraded my telerik controls from 2011.2.915.40 to 2012.1.215.40 with msi installer.
    After uprade I discovered that defaultbutton declared for asp:Panel does not fire postback on pressing
    the key Enter.
    Here is small example. It works fine with older Telerik.Web.UI, but not with Q1 2012.
    <%@ Page Language="C#" AutoEventWireup="True" CodeBehind="Default.aspx.cs" Inherits="Test._Default" %>
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
     
    <head runat="server">
        <title>Test</title>
    </head>
     
    <body>
        <form id="MainForm" runat="server">
            <telerik:RadScriptManager ID="RadSCM" runat="server" />
            <asp:Panel ID="pnlWrapper" runat="server" DefaultButton="btnSearch">
                <telerik:RadTextBox ID="tbSearch" runat="server" EmptyMessage="Search" Width="130" />
                <telerik:RadButton ID="btnSearch" ButtonType="StandardButton" Text="Search" ToolTip="Searching" runat="server" OnClick="btnSearch_Click" />
            </asp:Panel>
            <asp:Label ID="lblMsg" runat="server" />
        </form>
    </body>
    </html>
    using System;
     
    namespace Test
    {
        public partial class _Default : System.Web.UI.Page
        {
            protected void Page_Load(object sender, EventArgs e)
            {
                lblMsg.Text = string.Empty;
            }
     
            protected void btnSearch_Click(object sender, EventArgs e)
            {
                lblMsg.Text = "O.K. - Button fired";
            }
        }
    }

    Does anybody know where is the problem?
    Thanks
    -Marian
  2. Nick
    Nick avatar
    7 posts
    Member since:
    Sep 2010

    Posted 21 Feb 2012 Link to this post

    We are having this same problem.
  3. Grigore Dolghin
    Grigore Dolghin avatar
    19 posts
    Member since:
    Mar 2010

    Posted 21 Feb 2012 Link to this post

    Same problem here, although it's not related to asp:panel. My code is in page.load:

    Me.Form.DefaultButton = btnSave.UniqueID

    It just stopped working after update.
  4. Marian
    Marian avatar
    49 posts
    Member since:
    Sep 2008

    Posted 22 Feb 2012 Link to this post

    Hi guys,

    because this problem is serious for me, I have forwarded the same to Telerik as official support ticket.
    -Marian
  5. Dave
    Dave avatar
    38 posts
    Member since:
    Jul 2007

    Posted 22 Feb 2012 Link to this post

    Same problem here. I just upgraded this morning and this was the first thing i noticed. A fix or work around would be great.
  6. Slav
    Admin
    Slav avatar
    1359 posts

    Posted 22 Feb 2012 Link to this post

    Hello,

    We are aware of this problem and we are looking for a solution. Currently I am unable to confirm if it would be a fix for the problem or if it will remain as limitation of the new rendering of RadInput. There are several options for fixing the behavior of the RadTextBox control, which could be used for the time being:
    • You could still use the old rendering by setting the EnableSingleInputRendering property to false for your RadInputs.
    • You could set AutoPostBack to true for your Input if it is applicable in your scenario.
    • You could utilize the client-side event OnKeyPress in order to check if the pressed keyboard button is Enter and if it is, to click the RadButton programmatically (via its client-side method click()).

    Additionally you can check this forum thread.

    Feel free to let us know if you run into more difficulties.

    All the best,
    Slav
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  7. Grigore Dolghin
    Grigore Dolghin avatar
    19 posts
    Member since:
    Mar 2010

    Posted 22 Feb 2012 Link to this post

    I can't believe I was just read. I really really hope it will not "remain as a limitation of the new rendering of RadInput".

    Do you realistically believe we will going to hunt down all the textboxes in our apps to add that property? And even if we do, what about the comboboxes, which do not expose it?

    I am using validators and validation summary. User presses enter and I show him what and where to enter. Until last update everything worked smoothly, users were happy and I was happy too. Now they aren't happy anymore and guess what's my mood.

    Please put the defaultbutton back. I don't understand why such a breaking change, which make no sense anyway. Why choose a implementation which breaks a well established one?

    Besides that, if I press enter in a textbox on a form that has the DefaultButton property set, then the entire page stops working. Tab doesn't navigate to next control anymore, the browers eats 60-90% of the processor and the red upper right x cannot be clicked (all the processing goes to some javascript in the page).

    Guys, please FIX this. No "will remain as a limitation". Limitation doesn't mean "we broke it".
  8. Marian
    Marian avatar
    49 posts
    Member since:
    Sep 2008

    Posted 22 Feb 2012 Link to this post

    Grigore - I agree with you. Nevertheless defaultbutton functionality is not only one problem with RadInputs in Q1 2012. I found unexpected behavior also with their appearance (width) and focusation (sometimes user is unable to focus by click and edit text in enabled text box). But I must do some tests for checking dependencies.
  9. Nick
    Nick avatar
    7 posts
    Member since:
    Sep 2010

    Posted 22 Feb 2012 Link to this post

    I also noticed there are rendering issues for ie7 in the radnumerictextbox, raddatepicker, radtimepicker, and raddatetimepicker. I'm not sure how, but I'm guessing something was messed up when they minified the css skins.

    I think we are going to stick with the Q3 2011 build until they fix their Q1 2012 build. I suggest anyone reading this who has not updated to Q1 2012 does so with caution!!!

    Nick
  10. Mark
    Mark avatar
    6 posts
    Member since:
    Nov 2010

    Posted 23 Feb 2012 Link to this post

    We have numerous applications with Telerik Controls where we depend on the DefaultButton property of a panel. I just can't update all those applications untill this is fixed. 

    I cannot believe this will be a limitation!
  11. Vasil
    Admin
    Vasil avatar
    1596 posts

    Posted 23 Feb 2012 Link to this post

    Hello,

    We found a solution to this problem and it will be fixed for the next service pack of the RadControls.
    Please excuse us for the caused inconvenience.

    Greetings,
    Vasil
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  12. Dave
    Dave avatar
    38 posts
    Member since:
    Jul 2007

    Posted 23 Feb 2012 Link to this post

    That's great! Any idea of when that may be released?
  13. Marcel Rossi
    Marcel Rossi avatar
    9 posts
    Member since:
    Jul 2007

    Posted 23 Feb 2012 Link to this post

    That's good News.

    I am also awaiting that Fix.

    I use only the RadControls in all my Projects, whereever I can.
    At the Moment I should rollout a greater Solution to my customer but cannot, because that DefaultButton-Problem...

    Can you please tell us when you will release that service pack?
    Maybe I have to go back to the last Version... :-(

    Regards
    Marcel
  14. Vasil
    Admin
    Vasil avatar
    1596 posts

    Posted 24 Feb 2012 Link to this post

    Hello to all,

    The service pack is not tightly scheduled yet and could not be sure when it is. However by upcoming
    Tuesday we should have uploaded an internal build that to contains the fix. I would appreciate if you try it out, and share your results. It would be good to have feedback from wide range of real live scenarios.

    Greetings,
    Vasil
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  15. Mahesh
    Mahesh avatar
    1 posts
    Member since:
    Dec 2011

    Posted 28 Feb 2012 Link to this post

    Please provide instructions on how and where to download the internal update from!
    Thanks
  16. Mark
    Mark avatar
    6 posts
    Member since:
    Nov 2010

    Posted 28 Feb 2012 Link to this post

    I've downloaded the latest internal build here:
    http://www.telerik.com/account/your-products/product-versions/single-download.aspx?pmvid=2711&pid=561

    In this build the bug is fixed, thank you Vasil!
  17. Grigore Dolghin
    Grigore Dolghin avatar
    19 posts
    Member since:
    Mar 2010

    Posted 28 Feb 2012 Link to this post

    I am getting "Telerik is undefined" javascript error. I have unzipped the hotfix overwriting the old folder structure, then upgraded the website using Upgrade Wizard. Is there anything else I should do? (deleted the framework cache and visual studio cache).

    The error occurs here:
    WebForm_AutoFocus('frmMain_ctlLogin');Sys.Application.add_init(function() {
       $create(Telerik.Web.UI.RadAjaxManager, {"_updatePanels":"","ajaxSettings":[],"clientEvents":{OnRequestStart:"",OnResponseEnd:""},"defaultLoadingPanelID":"","enableAJAX":true,"enableHistory":false,"links":[],"styles":[],"uniqueID":"ctl00$myRadAjaxManager","updatePanelsRenderMode":0}, null, null, $get("ctl00_myRadAjaxManager"));


    The error occurs on a brand new website as well. What can i do to fix this?
  18. Grigore Dolghin
    Grigore Dolghin avatar
    19 posts
    Member since:
    Mar 2010

    Posted 01 Mar 2012 Link to this post

    Unistalled Q1 2012, installed it back, upgraded the dll in the bin folder and now it doesn't hang anymore, but still needs work.

    Create a blank new RadControls webpage. Drop an <asp:login> cotnrol on it and run the thing. Click the login button - it will show asterisks next to both textboxes.

    Run the webpage again, set focus in first textbox and press enter. It will show an asterisk next to that text box, and not to second one. That means user need to tab to next textbox and press enter, then tab to next one, press enter and so on, in order to get all the validation messages.

    I am rollling back to Q3 2011, and most probably this is my last ASP.NET project built with Telerik controls.

    Have a good day.
  19. Salvador Fernández
    Salvador Fernández avatar
    3 posts
    Member since:
    Aug 2009

    Posted 02 Mar 2012 Link to this post

    Some important things does not work in my project after upgrading to Q1 2012, too.


  20. Vasil
    Admin
    Vasil avatar
    1596 posts

    Posted 02 Mar 2012 Link to this post

    Hi Grigore,

    I will test the described scenario. If confirm the issue I will log it so our developers to fix it.

    All the best,
    Vasil
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  21. Shonda
    Shonda avatar
    36 posts
    Member since:
    Apr 2009

    Posted 05 Mar 2012 Link to this post

    Marian -- I have also noticed issues with width. I have a simple log on page with 3 text boxes. All are set to an absolute width of 200px yet the password TextBox with the property TextMode="Password" is noticeably shorter than the TextBoxes without setting the TextMode property.

    Luckily on the log on page I really do not need to use the RadControls so I was able to revert back to the normal ASP TextBox to fix the width problem as well as the DefaultButton problem. No so lucky on the other pages however and am eagerly waiting for the official service release so I can deploy my application. Until then I will stick with the previous version.
  22. Gary
    Gary avatar
    4 posts
    Member since:
    Mar 2012

    Posted 14 Mar 2012 Link to this post

    I recently upgraded to Q1 2012 and found the same issue with rad inputs not firing the default button ID and as a quick solution I added a skin file to my theme with the following definition for <rad:TexBox> :

    <telerik:RadTextBox runat="server" EnableSingleInputRendering="false"></telerik:RadTextBox>

    It's not the best solution but it should save any copy and paste errors in trying to find all instances of the controls throughout your applications.
  23. AJ
    AJ avatar
    3 posts
    Member since:
    Feb 2011

    Posted 09 Apr 2012 Link to this post

    Wow, there went 3 hours of my life until I found this out.

    Waiting for the patch.
  24. Vasil
    Admin
    Vasil avatar
    1596 posts

    Posted 10 Apr 2012 Link to this post

    Hi AJ,

    The input should work properly with the latest internal build, the official ServicePack for Q1 2012 will be available in few days.

    Greetings,
    Vasil
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  25. Marian
    Marian avatar
    49 posts
    Member since:
    Sep 2008

    Posted 11 Apr 2012 Link to this post

    Hi all,

    @Shonda: You have described exactly the same problem as my with width property in Password textbox. Because I use the same login control on many deployed applications - I still use Q2 2011. I hope that radinput control's behavior will come back as we are expecting in this thread.
    @Vasil: We are looking forward to SP.

    -Marian


  26. Tash
    Tash avatar
    15 posts
    Member since:
    Jul 2012

    Posted 26 Apr 2012 Link to this post

    Was this fix patch deployed yet? 
  27. Galina
    Galina avatar
    1 posts
    Member since:
    Apr 2012

    Posted 26 Apr 2012 Link to this post

    Please let us know when we can download a new version.
  28. Vasil
    Admin
    Vasil avatar
    1596 posts

    Posted 27 Apr 2012 Link to this post

    Hello,

    Then Service Pack is available since 11th of April, you could download if after you log into your account. Look for version 2012.1.411.

    Kind regards,
    Vasil
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  29. David
    David avatar
    3 posts
    Member since:
    Jan 2011

    Posted 03 May 2012 Link to this post

    I have upgraded my telerik controls from 2012.1.215 to 2012.1.411 with msi installer.
    After uprade I discovered...the solution is non 100% :-( !!!!!!!!
    one click ok!  | two ok! | three no ok!!!!!!....autopostback stopped!
    <telerik:RadTextBox runat="server" EnableSingleInputRendering="false"></telerik:RadTextBox>........is working but slowly

    RadWindow is non stabil too .-(
  30. Vasil
    Admin
    Vasil avatar
    1596 posts

    Posted 07 May 2012 Link to this post

    Hello David,

    You write here the code containing the inputs that you have problem with?

    I would ask you to post a formal support ticket and to describe the problems that you have with RadWindow, If it is something that is known you will get additional help, and if it is unknown issue we will do our best to resolve it.

    Regards,
    Vasil
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top