Problem with Commit in Graphity after update to v1.2

6 posts, 2 answers
  1. Answer
    Tonci
    Tonci  avatar
    22 posts
    Member since:
    Oct 2007

    Posted 06 Feb 2013 Link to this post

    FYI
    I see problem with Commit from Graphity after update to v1.2.

    For workaround, commithing from Mist is looking OK.

    Steps are:
    - open PlavetniloMobile project in Mist, commit all changes and than close Mist.
    - open same project in Graphity and check there is no any changes to commit.
    - Make small change in index.html, eg. add spaces in html comment
    - Commit changes
    - On "Version Control" dialog, "Changes" tab, it is displayed: "Changed Files: 555 added, 1 modified, 0 deleted, 0 renamed"
    - Than i add comment "test commit", click COMMIT and than wait for commit to happen
    - It never finish, number of files that are added is changing, it become cca 1500,  several moments latter it is again cca 500 than again cca 1500... very strange.
  2. Tom
    Tom avatar
    16 posts
    Member since:
    Jan 2013

    Posted 06 Feb 2013 Link to this post

    I just want to confirm the commit issue.  I just downloaded Graphite 1.2 and I am now not able to commit.  Or rather the commit is not happening.  After I commit, my changes still remain in graphite.

    Also, when I updated I had a few uncommited changes that I wanted to revert. After the update I went in to the commit dialog, checked 3 items, then clicked revert.  Only one item reverted at a time.

    Also, there is a .user-settings.xml file that I am not able to revert.  I assume that is something got added during the update to 1.2 and is needed but not sure.

    Version control is working in Mist.  Interestingly the .user-setting.xml file is not in the Mist commit list but other recent changes from Graphite are showing up.

    Thanks,
    Tom
  3. Answer
    Tonci
    Tonci  avatar
    22 posts
    Member since:
    Oct 2007

    Posted 06 Feb 2013 Link to this post

    Hello,

    After examining your project we have discovered that the reason for this misbehavior is due to an incorrect .gitignore file. We suspect that you have renamed your project, however the .gitignore file does not reflect that change, thus you see all ignored files (e.g. user settings, files generated during build) incorrectly as candidates for commit. This problem does not exist for new projects created with version 1.2, however existing projects created with version prior to 1.2 are affected.
    The easiest way to fix this problem is to edit the .gitignore file directly in GitHub and then pull in Graphite. The correct content of that file is the following one:

    bin/
    obj/
    *.user-settings.xml

    Please, excuse us for the inconvenience this might be causing you.

    Regards,
    Ivan
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  4. Tonci
    Tonci  avatar
    22 posts
    Member since:
    Oct 2007

    Posted 06 Feb 2013 Link to this post

    Hi Ivan,
    You provided exact solution for my problem :-) Thanks a lot!

    You are completely right. Month and half ago, I really renamed project name and then didn’t updated .gitignore file, because I’m still git n00b.

    First I did exactly what you suggested, than added some Google-fu related to .gitignore and after some house cleaning and several pulls, Graphite Version control is "shine and beauty" again :-)

    In my local repo:
    - pulled last version
    - updated .gitignore
    - deleted unneeded files from my local repo
    - git rm --cached -r bin/
    - commit, push

    Please guys continue doing what you are doing because it is great and powerfull magic ;-)
  5. Tonci
    Tonci  avatar
    22 posts
    Member since:
    Oct 2007

    Posted 06 Feb 2013 Link to this post

    Small note to all Graphite funs, 
    if you have problem with "silent commit misbehavior" and do not have idea what happened, remember, Fiddler is also your friend ;-)

    http://www.fiddler2.com/fiddler2/

    Kind regards
    Tonci
  6. Tom
    Tom avatar
    16 posts
    Member since:
    Jan 2013

    Posted 06 Feb 2013 Link to this post

    Hi Ivan,

    Thanks for the post.  Updating the .gitignore file as you said did the trick.  

    Steps to fix:
    1) Updated .gitignore file using GitHub and commited it.
    2) Closed Graphite as the pull menu was disabled.
    3) Opened Mist and pulled change.
    4) Opened Graphite and all was fixed up.  

    Life is good again!

    Thanks,
    Tom
Back to Top