Print Button does not open print dialog

2 posts, 0 answers
  1. StevenDale
    StevenDale avatar
    100 posts
    Member since:
    Apr 2007

    Posted 27 Sep 2010 Link to this post

    Reporting Q2 2010

    I have a telerik report inside of the report viewer of a sliverlight page. The reports opens up correctly. However, when I click the print button on the Report Viewer Control the print dialog does not display. IE progress bar refreshes but that is the only indication that anything at all is happening. This does not happen when I run the site on my local server. It happens when I deploy it to my development server. I am guessing I need to deploy some dll(s) that I have not deployed yet. Where can I find a list of the dlls that need to be deployed? NOTE: I have already deployed the following: Telerik.Reporting.dll, Telerik.Reporting.Services.dll and Telerik.Reporting.XamlRendering.dll.

    Thanks,

    Billy Jacobs
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 28 Sep 2010 Link to this post

    Hello Billy Jacobs,

    For a Silverlight application all relevant assemblies are embedded into the XAP file at compile time and there is no need to upload manually assemblies.
    Does this report contain a lot of report parameters with multiple selected values? There was such a problem that we've fixed in the Q2 SP1: Unable to print a report when the GET request is too big (e.g. multiple parameters or multivalue parameters with lots of selected values).
    If still having problems even with the service pack, please open a support ticket and attach a sample project that exhibits the problem.

    Best wishes,
    Steve
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft banner
Back to Top