period key not working

3 posts, 0 answers
  1. joshua odell
    joshua odell avatar
    30 posts
    Member since:
    Sep 2008

    Posted 11 Dec 2009 Link to this post

    I'm sorry for "Cross Posting" but I put this in the wrong forum originally
    I'm using the numeric up down for several measurement entries, the user is able to use the "." key on the numeric keypad, but not the "." key on the alphabet keyboard (next to the "," key and the shift key).

    is there a reason that the period key isn't allowed, and how do I get past it.  this is a big problem for my users, as they all use laptops with no "numeric keypad".
    Is there a workaround?

    Thank you

    Joshua
  2. Boyan
    Admin
    Boyan avatar
    758 posts

    Posted 14 Dec 2009 Link to this post

    Hello joshua,

     There was such problem but we fixed it in Q3 release. Could you please verify that you are using  Q3 or later  .dlls. Also could you please specify what culture you are using, because if in your culture "," is used as decimal separator you have to press "," on the keyboard.

     If the above doesn't help, could you send me a sample project where I can reproduce the issue because it is working fine at my side. Maybe some property or custom code is causing the problem.

    Sincerely yours,
    Boyan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for WPF is Visual Studio 2017 Ready
  4. joshua odell
    joshua odell avatar
    30 posts
    Member since:
    Sep 2008

    Posted 14 Dec 2009 Link to this post

    I can confirm that this was fixed in 09Q3 sp1, I'm not sure about the original 09Q3, but I downloaded the latest last night, and the issue is resolved.

    Thank you 

    Joshua
Back to Top