Pasting from Excel skips empty cells

2 posts, 0 answers
  1. Vinod
    Vinod avatar
    23 posts
    Member since:
    Nov 2011

    Posted 22 Oct 2015 Link to this post

    When copying multiple cells from an excel sheet to the GridView, empty cells are skipped and following non-empty cells are moved forward. See attached screenshots for an illustration.

    This behavior is undesirable for obvious reasons. Is this a bug or a feature. If it's a feature, is there a workaround?

  2. Maya
    Admin
    Maya avatar
    4062 posts

    Posted 22 Oct 2015 Link to this post

    Hello Vinod,

    You can modify this behavior by setting ClipboardPasteMode property of RadGridView. In this case you can set it to"OverrideWithEmptyValues". Check out the "Pasting" article for further reference, 

    Regards,
    Maya
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for WPF is Visual Studio 2017 Ready
Back to Top