Panelbar & XML

3 posts, 0 answers
  1. Robert Jakech
    Robert Jakech avatar
    34 posts
    Member since:
    Feb 2010

    Posted 17 Aug 2010 Link to this post

    Dear Telerik,

    I don't know what is wrong with my PanelBar. I am populating from XML, but when i click on the panelbar item, it does not redirect to my page.
    Below is my snippets:
    XML
    <?xml version="1.0" encoding="utf-8" ?>
    <PanelBar Skin="Outlook">
      <Item Text="Parameters" ImageUrl="~/Images/Crystal/images/gif/32.gif" Expanded="True" >
          <Item Text="GOOGLE" ImageUrl="~/Images/Crystal/folder/gif/16.gif" Href="www.google.com"/>
          </Item>
    </PanelBar>

    PANELBAR DEFINITION(.aspx)
      <telerik:RadSplitter ID="RadSplitter1" runat="server" Height="600px" Skin="Vista"
                    SplitBarsSize="" Width="1420px" BackColor="AliceBlue" BorderSize="2">
                    <telerik:RadPane ID="panelRadPane" runat="server" MinHeight="300" MinWidth="200"
                        Width="250" EnableEmbeddedBaseStylesheet="False">
                        <telerik:RadPanelBar ID="mainRadPanelBar" runat="server" Height="520px" AllowCollapseAllItems="true" ExpandMode="SingleExpandedItem">
                        </telerik:RadPanelBar>
                    </telerik:RadPane>
                    <telerik:RadSplitBar ID="mainRadSplitBar" runat="server" CollapseMode="Both" />
                    <telerik:RadPane ID="contentRadPane" runat="server" Scrolling="None">
                        <div class="span-24 last" id="ContentPlace">
                            <asp:ContentPlaceHolder ID="MainContentPlaceHolder" runat="server">
                            </asp:ContentPlaceHolder>
                        </div>
                    </telerik:RadPane>
                </telerik:RadSplitter>
    CODE BEHIND
     mainRadPanelBar.LoadContentFile("~/Resources/Xml/Menu.xml");

    Please kindly help. I don't know where i am going wrong.

    Much appreciated
    .


  2. Yana
    Admin
    Yana avatar
    4554 posts

    Posted 19 Aug 2010 Link to this post

    Hello Robert,

    Please replace "Href" with "NavigateUrl" in the xml  in order to fix this.

    All the best,
    Yana
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Robert Jakech
    Robert Jakech avatar
    34 posts
    Member since:
    Feb 2010

    Posted 19 Aug 2010 Link to this post

    Thanks very much.

Back to Top