Pages not displaying properly....

8 posts, 0 answers
  1. Geoff
    Geoff avatar
    28 posts
    Member since:
    Jul 2010

    Posted 04 Dec 2011 Link to this post

    Hi there

    I am having problems with the tabstrip and wondered if anyone can help.

    Basically the problem is when the tabstrip loads it displays all of the pages content - I have 4 pageviews - rather than just the selected tab.

    When I have clicked all of the of the 4 tabs then the pages display properly.

    I believe the issue is related to themes as we are using masterpages. When I try the same code on a non-master page aspx then it works fine,

    It is a strange one as we have a couple of other sites that use exactly them same mechanism and they all work spot on. We have made substantail use of the tabstrip before and have never encountered this.

    Can anybody point me a where the issue may lay as I have tried just about everything I can. As a said I think it is a setup issue rather than coding but cannot get to the bottom of it.

    Any help greatly appreciated.
  2. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 07 Dec 2011 Link to this post

    Hello Geoff,

    Actually we have not encounter such issue before and therefore I am not quite sure what is causing this appearance. Can you please provide some code that will help us reproduce this behavior so that we could test it locally and help you out with a suitable solution?

    Kind regards,
    Kate
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Geoff
    Geoff avatar
    28 posts
    Member since:
    Jul 2010

    Posted 12 Dec 2011 Link to this post

    Hi and thanks for the response.

    This issued has now been fixed.

    Was due to IE not being able to display CSS - added a style sheet manager and sorted issue.

    Thanks


  5. Imran
    Imran avatar
    25 posts
    Member since:
    Mar 2009

    Posted 08 Jan 2012 Link to this post

    Having same issue as Geoff.

    Geoff I added the style sheet manager but that did not help either.

    How did you get it working.

    Imran
  6. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 11 Jan 2012 Link to this post

    Hello Imran,

    Can you please open a support and send us a simplified runnable project that we can test locally since it is very strange behavior that we have not encountered yet. Can you also clarify the version of the Telerik controls that you are using?

    Regards,
    Kate
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  7. Imran
    Imran avatar
    25 posts
    Member since:
    Mar 2009

    Posted 11 Jan 2012 Link to this post

    I am sorry at the moment my schedule does not permit me to do so.

    Here was out layout though.

    Grid with user control as the edit form (modal popup), user control had the tabstrip. The tabstrip behaved as expected on most browsers except for IE9.

    If I get time I will try to create and submit a sample project.

    But for now we just decided not to use this approach to meet deadlines.

    Imran
  8. Imran
    Imran avatar
    25 posts
    Member since:
    Mar 2009

    Posted 11 Jan 2012 Link to this post

    Oh also the I was using the latest release where I encountered several new problems at multiple places in the application. Object not found errors that is.

    So we rolled back to 2011.3.1115 which fixed all other newly encountered problems (caused by new release) but we still had the problem with tabstrip.

    Imran


  9. Kate
    Admin
    Kate avatar
    1898 posts

    Posted 16 Jan 2012 Link to this post

    Hi Imran,

    Thank you for the information, but still it is not sufficient for replicating the issue that you get. Unfortunately I am not quite sure if I could help you since I am not able to replicate the issue on the first place. However, I will be happy to assist you once I have a runnable page that I can test locally.

    Greetings,
    Kate
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017