PageFiedls doesn't appear on RadPDFViewer

2 posts, 0 answers
  1. Dario
    Dario avatar
    61 posts
    Member since:
    Apr 2011

    Posted 25 Jan 2013 Link to this post

    Hi to all,
    I created a RadDocument by code, I'm using a PDFFormatProvider to export to a MemoryStream, then show document into RadPDFViewer.
    In this case PageFields inserted into header appears only in the first page.

    If I try to save a document as PDF File, PageFields appears in all pages.

    Why doesn't appears?

    Attachments
    • code.png - code that inserts a PageField into header documento
    • pag1.png - page where appears a PageField.Result
    • pag2.png - page where doesn't appears a PageField.Result
    • code2.png - code that export RadDocumento into MemoryStrem and then into RadPDFViewer
  2. Petya
    Admin
    Petya avatar
    975 posts

    Posted 30 Jan 2013 Link to this post

    Hello Dario,

    Thanks for contacting us with this issue.

    We investigated it and it looks like the problem is in the way RadPdfViewer shows the file, as when you try to open the saved to disk PDF file in our online demo, the results are the same as when passing a stream to a viewer as in your setup. The good news is that we tried opening such file in our development version and it seems to work as expected. Our next official release - Q1 2013, is expected in the of February and should solve the problem you are observing.

    Let us know if there is anything else we can help you with!
     
    All the best,
    Petya
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. DevCraft banner
Back to Top