Package Installation Error

Thread is closed for posting
8 posts, 0 answers
  1. Keith
    Keith avatar
    7 posts
    Member since:
    Mar 2013

    Posted 14 Mar 2013 Link to this post

    I just opened VS2012, created a new Kendo UI MVC Project, followed the wizard steps and was slapped with this (see image at Screen Shot - also attached file).  It appears I am missing a ton of jQuery, Modenizr, OAuth, knockout.js, razor packages and more.  Is this normal?  Do I need to track down each of these packages?  Once I do, will they be available for the next new project I create?

    TIA

    Keith
  2. Vesko
    Admin
    Vesko avatar
    97 posts

    Posted 14 Mar 2013 Link to this post

    Hi Keith,

    I am sorry for the inconvenience.

    That issue is most likely caused by Web Tools 2012.2 update. Currently our extensions do not support this update. In our next release (next week) we will provide a solution. Meanwhile you can convert a standard MVC4 project to Telerik one (Telerik  | Kendo UI for ASP.NET MVC | Convert to Kendo UI for ASP.NET MVC Application).
    Another reason may be an incompatibility with Visual Studio 2012. We do not support any beta version of the studio. The approach of converting MVC4 project to Telerik one will also work here.

    Please let me know if that is not the case.

    All the best,
    Vesko
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. UI for ASP.NET MVC is VS 2017 Ready
  4. Keith
    Keith avatar
    7 posts
    Member since:
    Mar 2013

    Posted 14 Mar 2013 Link to this post

    I ended up installing the NuGet packages manually using the latest for each of the ones missing.  My project, at least as bare bones as it is now, is running fine.  I will know more once I have enough of a model built to push up to the UI.  Thanks!
  5. David Larew
    David Larew avatar
    7 posts
    Member since:
    May 2010

    Posted 24 Apr 2013 Link to this post

    I'm seeing the same list of missing ref's.
    Is there a step by step to fix this?
  6. gm
    gm avatar
    17 posts
    Member since:
    Jul 2012

    Posted 29 Apr 2013 Link to this post

    Has this problem been resolved?  When I try to create a new "C# Kendo UI for MVC Web Application", I am seeing the same errors.    I am using a released version of VS2012 and have Kendo UI for MVC release 2013.1.319.

    Thanks
  7. Vesko
    Admin
    Vesko avatar
    97 posts

    Posted 30 Apr 2013 Link to this post

    Hi,

    This issue has been resolved in case you install Web Tools 2012.2 update only. However Web Tools 2012.2 update is redistributed by Update 1 and Update 2 of Visual Studio 2012 which in some cases leaves your registry inconsistent (if you have Update 2 installed without having Update 1 installed before for example). So if updating our extensions to the latest version do not fix the error - reinstall Web Tools 2012.2 update (LINK).

    Please let me know if that helps.

    All the best,
    Vesko
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  8. gm
    gm avatar
    17 posts
    Member since:
    Jul 2012

    Posted 30 Apr 2013 Link to this post

    Hi Vesko,

    Just wanted to let you know that re-installing the Web Tools 2012.2 update fixed the problem for me.

    Thanks
  9. dsterk
    dsterk avatar
    2 posts
    Member since:
    Sep 2011

    Posted 21 May 2013 Link to this post

    Hi Vesko,

    That worked for me as well.

    Thanks.
Back to Top
UI for ASP.NET MVC is VS 2017 Ready